GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
View RSS Feed

Ronny`s Big Block `Burb Blog

...a while since the last time I was here....

Rate this Entry
Quite a while, it could be that the car has been working excellent and that I have been very busy at work.
Well, the car has a problem......as described in this thread http://www.gmtruckclub.com/forum/sho...f-the-ignition

Strange some of those electrical problems, and really annoying when you can`t figure out whyyyyyy.
Well, during last weekend the solution was to take off the negative on the battery each time I stopped the car, avoiding it to drain the power. Monday, I picked up my Jeep and turned in my lovely burb to the mechanics. As I have put the Jeep up for sale, I now hope it is not getting sold before I have my precious back, fixed and healthy
They are at the same time going to replace the electrical window hoist on the drivers side. It is probably gonna cost a fortune , it usually does here in Norway.....
Well, nice to be back, I hope I can stay here a while now as it seems to be slightly calmer at work.

Rock on
Categories
Uncategorized

Comments

  1. Drake_korthos's Avatar
    Good luck with the Power fix! Had a buddy have a similar problem...course I think it had somethin to do with takin his SUV for a swim in a mud hole...!
  2. Ronny's Avatar
    Hehe, Thanks.
    Well I haven`t been in any mud hole, though it has been raining a lot. Hope they can find the fault by the time I get back from offshore......driving that 96 Jeep have made me REALLY miss my Suburban