GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER

Search:

Type: Posts; User: Gmcsuvguy

Page 1 of 12 1 2 3 4

Search: Search took 0.00 seconds.

  1. Sounds like a thermostat issue. If it doesn't...

    Sounds like a thermostat issue. If it doesn't heat up until you start driving it, try just revving up the engine and see if it blows warmer air, if it does you need a thermostat.
  2. Replies
    149
    Views
    12,815

    Well it used to be pretty simple, I drove a 01...

    Well it used to be pretty simple, I drove a 01 Yukon, a 99 Jimmy, before that was a 89 Jimmy, a 80 full size Jimmy, a 84 Jimmy and so on. Sold them all and now have 2 GMC Sierras, got to keep the...
  3. Replies
    13
    Views
    1,606

    I like the looks of the backflip also, need one...

    I like the looks of the backflip also, need one for my 10. Need to find a dealer here in Canada.
  4. I think you are pretty limited to any upgrades...

    I think you are pretty limited to any upgrades for your 95...
  5. Replies
    5
    Views
    1,901

    If the blower motor was loud the bearing was...

    If the blower motor was loud the bearing was probably goilg on it, causing a higher load on the electrical to turn it and was blowing the fuse. I agree that you probably need a new blower. Y ou can...
  6. Thread: new to forum

    by Gmcsuvguy
    Replies
    10
    Views
    668

    Welcome to the forum!

    Welcome to the forum!
  7. Replies
    7
    Views
    4,383

    Welcome, It could be the ABS sensor harness that...

    Welcome, It could be the ABS sensor harness that is causing your problem. You will have to get it scanned to find out which codes are being thrown.
  8. Replies
    15
    Views
    1,264

    Welcome! Well first of all I'm sure your Tahoe...

    Welcome! Well first of all I'm sure your Tahoe will live a long, long time. IMO tune ups are worth their weight in gold. Preventative maintenance is done for that reason "preventing" any issues. When...
  9. Replies
    440
    Views
    269,525

    Sticky: Here's my 2010 GMC Sierra, it's Carbon Metallic...

    Here's my 2010 GMC Sierra, it's Carbon Metallic Black. So far only a Diablo Predator programmer but a Air Raid CAI is on it's way and a tonneau cover.
  10. Replies
    14
    Views
    1,531

    Ok so do you have to remove all those fuse that...

    Ok so do you have to remove all those fuse that they say to prior to installing the DSP? I did when I loaded it on my Denali but was always wondering if it was neccessary. Going to order another one...
  11. Replies
    6
    Views
    1,072

    My New 2010 Sierra Crew

    Well had do it, got rid of the last SUV I had and bought another new Sierra, this one is my work truck so the wife gets the Denali. This one is a 2010 with the 5.3l, Crew cab, automatic 4X4, etc....
  12. Replies
    2
    Views
    521

    You have some serious issues. I don't know where...

    You have some serious issues. I don't know where you should start but obviously with wiring messed up somewhere... Good luck
  13. Replies
    2
    Views
    949

    Disconnecting the battery will not clear codes...

    Disconnecting the battery will not clear codes for you and they will stay on until cleared with a scanner, or if the problem is not there anymore it takes 40 ignition cycles to clear it.
  14. I think you got a good deal , and luckly thats...

    I think you got a good deal , and luckly thats all it was.
  15. Replies
    2
    Views
    964

    Are you in 4X4? Don't turn so sharp and wa-la...

    Are you in 4X4? Don't turn so sharp and wa-la fixed! There is always an easy fix to everything...:rofl:
  16. Replies
    5
    Views
    3,624

    My 01 Yukon had the piston tick noise, it went...

    My 01 Yukon had the piston tick noise, it went away after about 5 minutes, never got any worse.
  17. Replies
    6
    Views
    835

    What gears did you have/not have? Did you have...

    What gears did you have/not have? Did you have 1st, & 3rd maybe instead of 1 & 2nd? Did you have reverse?
  18. Replies
    3
    Views
    1,450

    I haven't heard of anything for a laptop, best...

    I haven't heard of anything for a laptop, best bet is to go to autozone or a shop similar, tey will normally scan it for you. Could be switch itself, module or encoder motor but they normally throw a...
  19. Replies
    10
    Views
    1,798

    Nice ride, good luck with it.

    Nice ride, good luck with it.
  20. Replies
    9
    Views
    3,582

    There was an updated slip yoke for awhile and...

    There was an updated slip yoke for awhile and then GM came out with their special lube, I don't have the part # but if you go into your local dealer they will have it..or can find it for you. The tin...
  21. Replies
    5
    Views
    3,624

    Was the engine cold? Some of the engines had...

    Was the engine cold? Some of the engines had piston "slap" until the engine warmed up and then it would go away. Or did it sound like lifter clicking?
  22. Replies
    10
    Views
    4,232

    If all the other buttons are working my guess is...

    If all the other buttons are working my guess is that, that button is not working, they are replaceable individually.
  23. Replies
    22
    Views
    2,504

    Sharp looking unit! I like the chrome on white,...

    Sharp looking unit! I like the chrome on white, starting to accumulate chrome for my truck too.
  24. Replies
    4
    Views
    2,237

    If you have a engine oil cooler it can be a line...

    If you have a engine oil cooler it can be a line either disconnected or a hole in it. Gotta get dirty and climb under your truck. Good Luck!:great:
  25. Replies
    8
    Views
    891

    My 2001 Yukon did the same thing, I fixed mine by...

    My 2001 Yukon did the same thing, I fixed mine by trading it in on a new truck!!:lol:
Results 1 to 25 of 279
Page 1 of 12 1 2 3 4