GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER

Search:

Type: Posts; User: xJCross

Search: Search took 0.01 seconds.

  1. Replies
    7
    Views
    3,307

    I did, yes. Should have mentioned that with the...

    I did, yes. Should have mentioned that with the throttle body post. That was cleaned when I took off my TBI. Thanks for checking though.
  2. Replies
    7
    Views
    3,307

    Hopefully, if anyone has this same problem...

    Hopefully, if anyone has this same problem they'll find this and know what to check for. I've been meaning to come give some feedback about my situation and it slipped my mind.

    So, the truck was...
  3. Replies
    7
    Views
    3,307

    Update: Cleaned out the throttle body, it wasn't...

    Update: Cleaned out the throttle body, it wasn't too bad inside. Replaced the gasket and put in a new IAC last week. Still had idling issues.

    So, today we took a pressure gauge and checked the...
  4. Replies
    7
    Views
    3,307

    I guess everyone's as stumped as I am haha. We...

    I guess everyone's as stumped as I am haha. We pulled apart and cleaned my throttle body and IAC valve yesterday and determined I need a new IAC. I'll post back if that fixes my problem finally.
  5. Thread: New from TN

    by xJCross
    Replies
    4
    Views
    737

    Been there and through there several times. I...

    Been there and through there several times. I have a few friends in the 'Boro.
  6. Thread: New from TN

    by xJCross
    Replies
    4
    Views
    737

    New from TN

    Hello

    I'm Joseph, and while I'm originally from Lawrenceburg, TN I now reside in Cookeville, TN where I'm attending graduate classes at TTU.

    I drive an automatic 1991 S10 extended cab with the...
  7. Replies
    7
    Views
    3,307

    91 S10 Surging/Bad idle

    I'm running out of my own ideas. So, I've come here hoping to find some answers.

    I have a 1991 Chevy S10 with the 4.3L V6 TBI. When the problem first began, it felt like just bad gas. It would...
Results 1 to 7 of 7