GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER

Search:

Type: Posts; User: Jim Beard

Search: Search took 0.00 seconds.

  1. Replies
    2
    Views
    503

    Well it says only 55psi with the key on test...it...

    Well it says only 55psi with the key on test...it read 54 before I replaced the fuel filter and 55 after....I guess I will have to lay out the money for a new fuel pump.....well, you can't take it...
  2. Replies
    2
    Views
    503

    fuel pump pressure

    fuel pump pressure indicates 55 psi...the only info I have says it needs 66psi, anyone have any other numbers?....1999 5.7 liter gasSuburban

    ---------- Post added at 04:43 PM ---------- Previous...
  3. Replies
    4
    Views
    616

    Yes I have checked the actual fuel...

    Yes I have checked the actual fuel pressure....just to make sure, I also had changed out the relay last weekend and still was good...I keep looking for something like a loose or broken connector on...
  4. Replies
    4
    Views
    616

    Surburban from hell

    99, 5.7 2wd,OK, started fine a week ago after the engine rebuild at 120,000miles, fuel pump working, new fuel filter, gas up to the line up to the intake manifold...NO START, dumped gas down...
  5. Replies
    11
    Views
    2,306

    I just finished rebuilding my 5.7L (350) engine...

    I just finished rebuilding my 5.7L (350) engine w/119,000 miles...oil pump shaft is held in place by a CHEAP piece of nylon....mine nylon split into 3 pieces at 70 mph...no oil pressure....ruined...
  6. Replies
    4
    Views
    3,322

    Thanks Stephan, and leaving the battery connected...

    Thanks Stephan, and leaving the battery connected is exactly what I did. I am still putting the engine back together but I hope it will do the same for me. The oil pump shaft collar broke doing...
  7. Replies
    4
    Views
    3,322

    speedometer problem

    1999 Suburban, 5.7, hooked up my battery charger to charge dead battery, speedometer now reeds 100 mph all the time. any reset / repair suggestions?
  8. Replies
    12
    Views
    3,819

    5.3 liter engine

    I am going to look at a 2004 Suburban this weekend with a 5.3 liter engine. I am more familiar with the old 305's and 350's. Can anyone give me some tips on what to look for or check?
    Thanks,
    Jim
  9. Replies
    9
    Views
    1,091

    Howdy from Texas

    Just found you today. Bought a 99 Sub Dec. 22, 2008. 350LS, 2wd...Plan to use it to haul Boy Scouts around. Got a camping trip on Jan. 23.
    I live in Chappell Hill, Texas about midway between...
Results 1 to 9 of 9