GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER

Search:

Type: Posts; User: cdffireboy

Search: Search took 0.00 seconds.

  1. Replies
    4
    Views
    1,012

    I had that slap on my 01 from the time I got it...

    I had that slap on my 01 from the time I got it with 67k miles and when I sold it recently at 184k it still had it but had never gotten worse. If I dint give it a chance to warm up it would sound...
  2. Replies
    8
    Views
    651

    ok finaly got some pics taken.. had to do only...

    ok finaly got some pics taken.. had to do only the front and passenger side since the sun was overhead,, and of course shes a tad bit dirty.. but hey it is a 4x4.. lol 4485544856
  3. Replies
    4
    Views
    953

    i would check the tranny control module first,...

    i would check the tranny control module first, its mounted next to the ecm behind the glove box, had issues with my 93 yrs ago and that was the prob. 50 bucks from a wrecking yard,, just make sure...
  4. Replies
    8
    Views
    651

    Ill take some decent ones tomarrow and get them...

    Ill take some decent ones tomarrow and get them posted up.
  5. Replies
    8
    Views
    651

    New guy from California

    Just saying hi from the central valley of California. driving a 2004 silverado 2500 4x4 with a 6.0 gas guzzling horsepower maker.. since im a do it yourself kind of guy, i figured i would join up...
Results 1 to 5 of 5