GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER

Search:

Type: Posts; User: DoubleDD

Search: Search took 0.00 seconds.

  1. Replies
    1
    Views
    187

    Starting issues?????1999 Suburban 5.7

    Have replaced fuel pump and put on new starter. Wasn't driving the truck for a couple months so I was doing some preventative maintenance. Now the truck will crank over and then the starter grinds...
  2. Replies
    13
    Views
    1,232

    Changed the fuel filter and now she's just like...

    Changed the fuel filter and now she's just like new! Full of gitty up and Go!
  3. Replies
    6
    Views
    2,807

    Bought 2 new front bearings from Bearing...

    Bought 2 new front bearings from Bearing Warehouse online for $200 shipped to my door. Replaced them and the problem was gone.
  4. Replies
    3
    Views
    512

    Just put on a new rotor and cap and checked all...

    Just put on a new rotor and cap and checked all plugs and wires in summer and they looked great.
  5. Replies
    13
    Views
    1,232

    245000kms. have not done the fuel filter change...

    245000kms. have not done the fuel filter change since I had the truck. About 2 years.
  6. Replies
    3
    Views
    512

    engine rpm troubles

    99 K1500 suburban. 350 engine. Engine revs up only if slow acellerator push but if sudden depress of gas pedal then engine seems to stop increasing in rpm and kind of diesels and stays at that rpm...
  7. Replies
    6
    Views
    668

    Found problem. Bundle of wires behind alt in...

    Found problem. Bundle of wires behind alt in black sheath was not clipped into holder and would move back towards manifold and melted sheathing on backside. Thus when starting and the wires were...
  8. Replies
    3
    Views
    844

    My 99 same thing. Other than connection under...

    My 99 same thing. Other than connection under seat and if no fuse blown then what. Mine just stopped working one day. All fuses are good.
  9. Morden, MB

    Morden, MB
  10. Replies
    13
    Views
    1,232

    no high speed engine rpm??????

    99 K1500 suburban. 350 engine. Engine revs up only if slow acellerator push but if sudden depress of gas pedal then engine seems to stop increasing in rpm and kind of diesels and stays at that rpm...
  11. Replies
    6
    Views
    2,807

    My 99 does the exact same thing! Any help with...

    My 99 does the exact same thing! Any help with suggestions? Wheel bearing or sensor? Won't show up on computer when mechanic rides with.
  12. 99 GMC Suburban K1500 4x4 from MB, Canada

    Small town guy with 99 Suburban
  13. Replies
    6
    Views
    668

    They do have some green corrosion but not too...

    They do have some green corrosion but not too bad. I also forgot to mention that while driving if I hit a sharp bump the engine will cut out for a split second and resume.
  14. Replies
    6
    Views
    668

    starting issues

    hard starting issues. 99 suburban 5.7 .battery tested good. connections clean and tight. new starter and starter solenoid. Sometimes while starting complete loss of electrical power for split second....
Results 1 to 14 of 15