GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER

Search:

Type: Posts; User: dpaul84@hotmail.com

Search: Search took 0.00 seconds.

  1. Replies
    12
    Views
    3,590

    NEW ISSUES After I put in a new PCM, all was...

    NEW ISSUES

    After I put in a new PCM, all was well for about five thousand miles, then I began having torque converter shudder. If I was just maintaing speed it was fine, but if I tried to lightly...
  2. Replies
    12
    Views
    3,590

    Right now i've got about fifteen hundred in it. ...

    Right now i've got about fifteen hundred in it. But most of that was all body. I bought this truck fresh outta high school and was pretty rough on it. About two years ago the transmission went out...
  3. Replies
    12
    Views
    3,590

    Ended up replacing the PCM because the code just...

    Ended up replacing the PCM because the code just kept coming back and sometimes I wouldn't get any power to the transmission at all and had third gear only. Had the PCM in for three days now without...
  4. Replies
    12
    Views
    3,590

    Well I thought I had it fixed. I sprayed brake...

    Well I thought I had it fixed. I sprayed brake cleaner in the connector on the transmission and the blew it dry with compressed air. Hooked it up to the scanner and all was well. Test drove and...
  5. Replies
    12
    Views
    3,590

    You seem to be very knowledgeable on this and...

    You seem to be very knowledgeable on this and your input is appreciated. I thought my external connector was bad, but my leads for my voltmeter were too large to fit in the pins, got a different set...
  6. Replies
    12
    Views
    3,590

    Fixed range sensor today and it now starts...

    Fixed range sensor today and it now starts without my added wire running to the starter relay so i removed that. Cleared all codes and went for a test drive. Transmission shifted and seemed fine...
  7. Replies
    12
    Views
    3,590

    4l60 issues after rebuild

    Thanks in advance for all replies. I have a 1997 k1500 4x4. Factory transmission went out and i bought a rebuilt one from a local transmission shop. It lasted for about 30,000 miles then lost...
  8. Replies
    0
    Views
    1,571

    1997 4L60E Problem

    97 chevy silverado 4x4 Transmission started slipping and was clearly going out. Bought a rebuilt transmission and installed and flushed coolant. Worked perfectly for 25,000 miles then quit shifting...
Results 1 to 8 of 8