GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER

Search:

Type: Posts; User: Sub Steve

Search: Search took 0.00 seconds.

  1. Replies
    9
    Views
    8,766

    OK, I think I’m a little further along since I...

    OK, I think I’m a little further along since I borrowed some equipment from a neighbor. I hooked up his ammeter in series and discovered that my draw is 19ma. The strange about this is that it...
  2. Replies
    9
    Views
    8,766

    Today I hooked up the multimeter inline with the...

    Today I hooked up the multimeter inline with the battery again. I think I was using the wrong setting previously. I have the negative battery cable disconnected. I put the red end of the...
  3. Replies
    9
    Views
    8,766

    Today I unhooked the negative battery terminal...

    Today I unhooked the negative battery terminal and put my multimeter inline between the negative cable and the negative post. I tried using the millivolt setting, but it gave the OL error message,...
  4. Replies
    9
    Views
    8,766

    2003 Suburban battery draining

    The battery on my 2003 Suburban keeps being drained. I charge it up to 12+ volts and overnight it drains to about 5-6 volts. I believe I have ruled out a bad battery as I have switched it with...
  5. Replies
    0
    Views
    610

    Oil Pressure Gauage

    On my 2003 Chevy Suburban, my oil pressure guage normally runs between 40-50. Lately it has been pegged at 80. Is that more than likely a guage problem or is there something that would suddenly...
  6. Replies
    1
    Views
    853

    Climate control not working

    First thing is that I am not very "automotive" so please bear with my lack of knowledge on explaining these things.

    I have a 2003 Chevy Suburban with electronic climate control. The display...
Results 1 to 6 of 6