GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER

Search:

Type: Posts; User: will89

Search: Search took 0.01 seconds.

  1. Replies
    4
    Views
    2,340

    yeah ive done most of that. problem is that when...

    yeah ive done most of that. problem is that when the compressor cycles off the pressure shoots way back up into the 90+psi. Its supposed to remain stable in the 40s. Not sure why it is constantly...
  2. Replies
    4
    Views
    2,340

    Normal cycling and compressor temperature?

    Just retrofitted my 89 sub from r12 to 134. I put 8oz.s of ester into the compressor and hand turned it since it had not been run in about 2 years ( the system still had some pressure until I broke...
  3. Thanks for the tips guys. Ive been outta town...

    Thanks for the tips guys. Ive been outta town since my last post but I ended up getting a relay from the junkyard....and whadduknow? Its fixed!! Thanks again guys
  4. The dash gauge seems accurate as it reads the...

    The dash gauge seems accurate as it reads the same as my volt meter. I'll follow up on some of your suggestions and get back to you guys with my findings. Im headed out of town now for about a week....
  5. If I am interpreting the schematic correctly the...

    If I am interpreting the schematic correctly the voltage only pulls from the relay when the fan is set to high. At low and medium setting it bypasses the relay.

    Does anyone know a method to check...
  6. A/C Blower pulling too many volts on high setting??

    Howdy folks. Ive got an electrical gremlin on my 89 Sub that I hope some of you have seen before.

    When I turn on my vent fan to the low or medium settings all is well. However when I turn the fan...
Results 1 to 6 of 6