GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER

Search:

Type: Posts; User: nelsont

Search: Search took 0.00 seconds.

  1. Replies
    5
    Views
    2,553

    Thanks for the advice guys, seem to have found...

    Thanks for the advice guys, seem to have found the problem. Replaced bulbs after cleaning socket,not that dirty, and all seems to be working!
    Kinda weird but we will see.
    Tim
  2. Replies
    5
    Views
    2,553

    brake lights not working

    Hi guys, looking for some direction.
    On my 2003 Chev ls1500 4wd 1/2 ton pickup.

    Problem is my brake lights are not lighting when brake pedal is pushed. #rd brake light on back of cab does light....
  3. Thread: No Start- Help

    by nelsont
    Replies
    5
    Views
    818

    Dealer called tonight and they have tracked it...

    Dealer called tonight and they have tracked it down to the the fuse box. Nothing $500 wont fix!
    Tim
  4. Thread: No Start- Help

    by nelsont
    Replies
    5
    Views
    818

    No, not a sound. Thats what is so strange. Like I...

    No, not a sound. Thats what is so strange. Like I said I replaced starter and neutral safety swithch on tranny. Battery seems strong.
    Tim
  5. Thread: No Start- Help

    by nelsont
    Replies
    5
    Views
    818

    No Start- Help

    Hi guys am new to site but am sure there is good advice on the is forum.

    My issue is with my 2003 Chevy Silverado 4.3 V6 regular cab 4x4 with 4 speed auto transmission.

    Came home from work...
Results 1 to 5 of 5