GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER

Search:

Type: Posts; User: Mike Woj

Search: Search took 0.00 seconds.

  1. Replies
    15
    Views
    1,843

    Hi Wags, I have a 97 Suburban with a 5.7. I...

    Hi Wags,
    I have a 97 Suburban with a 5.7.
    I recently replaced the engine.
    During the installation ceramic coated Flowtech headers were installed instead of the cast iron manifold.
    The vehicle...
  2. Replies
    8
    Views
    1,072

    I finally solved the problem. The help did not...

    I finally solved the problem.

    The help did not come from GM support, anything on the Internet nor anyone on this site.
    I am still amazed that this thread has had over 400 views and only one...
  3. Replies
    8
    Views
    1,072

    I had the Catalytic converters installed. They...

    I had the Catalytic converters installed.
    They could not use generic Cats so I had to buy the entire Y pipe.
    The install was $471.00.
    I still get both forward O2 sensors.

    This is getting...
  4. Replies
    8
    Views
    1,072

    The saga continues... The muffler is not...

    The saga continues...
    The muffler is not plugged.

    I had the engine smoked.
    There was a leak at the TBI to air box seal.
    Fixing it did not help.
    I still get a Service engine light for both...
  5. Replies
    15
    Views
    1,843

    I put a Magna flow on mine the dual in and dual...

    I put a Magna flow on mine the dual in and dual out. It used to be a dual 2" into a single 2 3/4" out of the tail pipe.
    Now it is dual 2 1/4" in and dual 2 1/4" out. One outlet was extended over to...
  6. Replies
    8
    Views
    1,072

    I took the Suburban back from them earlier this...

    I took the Suburban back from them earlier this evening.
    Today all they did was pull a bank of plugs and inspect them.
    They said they have run out of ideas.

    I drove it home with a service engine...
  7. Replies
    4
    Views
    1,055

    Check your radiator or overflow tank, if it looks...

    Check your radiator or overflow tank, if it looks like a foamy yellow milkshake then the transmission cooler in the radiator has leaked and that is were your transmission fluid is going. Also check...
  8. Replies
    8
    Views
    1,072

    Thanks for the reply. They had a problem with...

    Thanks for the reply.

    They had a problem with the timing in their first attempts to get it running.
    They killed the battery several times and I had to replace it.
    They said they were off by one...
  9. Replies
    3
    Views
    443

    New member from Interlachen Florida

    Hi,
    I hail from a very small town in North Central Florida.
    Interlachen is located between Jacksonville to the North and Ocala to the South, Gainesville to the West and Palatka to the East.
    My GM...
  10. Replies
    8
    Views
    1,072

    New 5.7 l engine throwing MILs

    Hi,
    I'm new to the forum and I need some help.
    I feel I need to give some detail, so this is pretty long.

    I have a 1997 K1500 Suburban with 120,000 miles. We bought it in the fall of 2012 for...
Results 1 to 10 of 11