GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 9 of 9
  1. #1

    Question Blower motor ??'s

    I have an '03 Silverado K3500. This past summer, the blower motor quit working on (5) high. The other 4 speeds all work fine, just the high speed is inop. It wasn't an issue in the summer, but now it is cold and I need a little more heat in the cab.

    Is the resistor the most likely cause of this or am I in need of a new switch?

    If it is the resistor, where is it and is it a pain to get to?

    Is GM only the best option or is the aftermarket a viable parts solution?

    Any and all help will be appreciated. My frozen feet thank you!!

  2. #2
    Jr. Engineer Rumpamuro's Avatar
    Join Date
    Apr 2007
    Location
    Mississauga, Ontario (Canada)
    Posts
    233

    Default

    most likely the resistor, pull the blower motor out, (under pass. kick panel) you may have to remove other plastic covers to get to it, once removed, look right behind the motors fan housing is and youll see it there, usually, 3 8mms on the motor, and 2 on the resistor, 1/4" ratchet, and an extension are usually the best tool. Good Luck!

  3. #3

    Default

    Did you ever get this figured out? My 2004 1500 is doing the same exact thing. 5 was intermittent for a while, now it's completely dead.

    Thanks.

  4. #4

    Default

    Quote Originally Posted by huminski View Post
    Did you ever get this figured out? My 2004 1500 is doing the same exact thing. 5 was intermittent for a while, now it's completely dead.

    Thanks.
    Yes. It was the ballast resistor. Of course, I didn't get off my fat a$$ to fix it until every speed went out on a Friday night in January on a road trip to western NE. Almost 100 miles with no heat at all.

    Stop by your local stealership and ask for the ballast resistor. They may need your VIN due to a change in the resistors mid year. The P/N I received is 89019088, list price $54.42. This is the one that has replaced the one I pulled out. The one I pulled out had P/N 15305077. It is no longer used and is replaced with the new # on 03's and up.

    Fairly easy to do, also. Just pull 4 screws out of the cover under the glove box. The 2nd one in from the driver's side is a bitch and I didn't put it back. No rattles. You will need 1/4 drive and a deep well 8mm (I think) socket for the cover. You will see the resistor. There is a 7 pin connector oriented straight down and a 2 wire pigtail routed to the rear of the blower motor housing. The resistor comes out by removing 2 screws with a 5.5mm socket.

    Now the interesting thing is, the new resistor is just a little different. The pigtail is quite a bit shorter and the resistor needed to be mounted in reverse for the pigtail to reach the connector on the housing. This is not a big deal. The cover plate that is holding the old one in will not work with the new resistor. Not a problem. I didn't install it back in mine and have no problems.

    HTH and good luck.

    Greg
    "Life should NOT be a journey to the grave with the intention of arriving safely in an attractive and well preserved body, but rather to skid in sideways, chocolate in one hand, margarita in the other, body thoroughly used up, totally worn out and screaming WOO HOO- What a Ride!"

  5. #5

    Default

    Thank you, I will order the part.

  6. #6

    Default

    Thanks for the info. I have been having this same problem with my truck, will get the part and replace. Sure is nice to have my question answered!!!!!

  7. #7

    Default

    Quote Originally Posted by sidnaw59 View Post
    Thanks for the info. I have been having this same problem with my truck, will get the part and replace. Sure is nice to have my question answered!!!!!
    Another satisfied customer.

    Steve
    10 Chevy Traverse LT AWD
    02 Chevy Trailblazer LS (110K+ miles - loaded except for 4WD - WRECKED!)
    99 Chevy Cavalier LS (105K+ miles - commuter car)
    78 Chevy Suburban Silverado (454, 3/4 ton)
    62 GMC 3/4 ton Pickup (350 police interceptor)

    Remember: Search Before Posting | Fill out Your Profile & Signature
    * I've been saying for years that I was going to change my username, and I finally did.

  8. #8

    Default

    Greg, Thanks a lot. 03 Suburban, fan quit on dash control all speeds. Took your post, went to Chevy, paid $65 and installed new part backwards and I am a hero at my house. Outsite temps are over 100 for weeks. Thanks for the great details.
    Johnboy

  9. #9
    Master Mechanic
    lancer's Avatar
    Join Date
    Aug 2009
    Location
    Farmersville, Illinois, United States
    Posts
    611

    Default

    i've got the same problem in my 06 with speed #5 going out. i'll have to look into it more now.....Thanks Guys!!


    2002 Tahoe LT---------TINTED WINDOWS------------7" DUAL DVD INDASH

Similar Threads

  1. blower motor
    By acc2108 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 4
    Last: 12-03-2010, 08:03 PM
  2. Blower Motor
    By TheShamrock7 in forum Chevy Trailblazer Forum (GMC Envoy)
    Replies: 0
    Last: 05-12-2010, 11:15 AM
  3. Blower motor
    By jb9164 in forum General Chevy & GM Tech Questions
    Replies: 0
    Last: 02-24-2009, 07:37 PM
  4. blower motor
    By net86browns in forum General Chevy & GM Tech Questions
    Replies: 7
    Last: 01-01-2009, 11:21 AM
  5. blower motor
    By ChevyPrincess in forum General Chevy & GM Tech Questions
    Replies: 3
    Last: 09-15-2008, 06:13 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •