GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 6 of 6

Threaded View

  1. #1

    Default 88 Chevy - Turn Signal Issue

    Hi, my truck is a 88 Chev 1500, with a rebuilt 1989 Astrovan 4.3 motor. This is what was explained to me when I bought it for $2200, about 11 years ago. I'm no mechanic so, basically I took the owners word on the whole rebuilt thing.

    Anyways the truck has served me well.

    Currently I'm having some issues with turn signals. I think it's been problematic for a few years cause, I seem to be replacing bulbs quite frequently. Anyways this issue that started a couple days ago went like this.

    I got a fast blink happening on the gauges turning left, then shortly thereafter the right did the same. I got home and checked the bulbs all around. All was good. Then later that day I jump in the truck and I'm getting nothing on the dash signals and no clicking sound from the relay. I replaced the 4 blade relay, and still nothing. I noticed there is a 5 blade relay next to it. Should I replace that? I have no idea if it has anything to do with the turn signals. Oh and I checked the fuse, it's fine.

    Update: Ok I replaced the 5 blade too. Still no go. I have normal blinking dash and truck lights when the hazard is pulled. I still get no dash blinking on both arrows when the lever is actuated, and no exterior lights blink. All light bulbs are good. Fuse is good.

    So what's left. Faulty Turn Signal Switch?

    Any help would be much appreciated.

    Thanks
    Last edited by Deek; 09-30-2012 at 01:24 PM.

Similar Threads

  1. Turn Signal Issue
    By Crakums_GT in forum GM Electrical Tech
    Replies: 5
    Last Post: 01-03-2013, 08:56 PM
  2. Turn Signal / Hazard Flasher Issue
    By eavaught in forum General Chevy & GM Tech Questions
    Replies: 3
    Last Post: 11-29-2010, 07:28 AM
  3. 1996 suburban 1500 turn signal issue
    By barryT in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 16
    Last Post: 11-27-2009, 06:33 AM
  4. turn signal issue
    By lcolletk in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 5
    Last Post: 06-04-2009, 10:13 PM
  5. 99 Chevy tahoe shuts off when the turn signal is used.
    By electricart in forum Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)
    Replies: 4
    Last Post: 05-15-2009, 09:59 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •