GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 3 of 3
  1. #1

    Default Got my Cree LED back up lights but.....

    Well, I had ordered my reverse bulbs from V-LED at the beginning of August and arrived on the 27th of September because of back order. Got them installed and they worked great..... for less than a day. I had went to unlock my truck and one of the bulbs let out a flicker of bright white light and the LED in the projector part is dull compared to the other. I am posting a link to my truck album on photobucket so you all can see what I am talking about. Sooo after a long delay, then getting them, I gotta send them right back and wait another long time. This isn't my first issue with LED's either. I had ordered a set of Cree style switchbacks from iJDMToy and one of them didn't work well, took it back and got a replacement and so far, they are working great. But, I had also bought some 921's for my cargo lamps and now only one works. So I have to go swap those now. I guess LED lighting isn't working for me that well... Anyways, here is the link. Thoughts?

    http://s467.photobucket.com/albums/r...001/silverado/

  2. #2

    Default

    I am not exactly sure what is going on. With the cheaper LED's you have to have load resistors on all the small bulbs. I have seen some manufacturer's of LED off road lights use high and low voltage protection on the led's otherwise you could surge them and burn them out with too much power.

    I would love to use some 1000 lumen cree led's in my tail lights.

    I checked the website where you bought those led's from and don't see the model you have in your pics on photo bucket.

  3. #3

    Default

    Well according to the V-LED website, it says they are plug and play and don't require resistors or anything. I shipped them back and have new ones on the way so we will see what happens I guess

Similar Threads

  1. Replies: 0
    Last Post: 05-21-2012, 07:10 PM
  2. no back up lights
    By freddie in forum GM Electrical Tech
    Replies: 16
    Last Post: 04-25-2012, 12:39 AM
  3. New Back-up Lights
    By groceryman in forum Chevy Truck Accessories
    Replies: 9
    Last Post: 05-18-2011, 06:02 PM
  4. No back up lights!!!
    By mwolfe25 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 5
    Last Post: 03-25-2010, 07:09 AM
  5. Back up lights
    By Rlee in forum Chevy Truck Accessories
    Replies: 15
    Last Post: 01-31-2010, 12:52 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •