GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 5 of 5
  1. #1

    Default 2001 2500hd trans issue

    Ive looked into possible issues on the site but i dont think mine fits under any of the ones i read about on the site .. I have a hard 1-2 shift. It only does it when the trans gauge is 1/4 from 0. And if im not on the gas too much it will hold 1st gear way too long and the do the hard shift ( almost like i had the truck in just first gear). The thing that gets me is that my trans temp doesnt really move up much from 0 and when it does itll go to 1/4 and thats when i get a fairly hard shift . Also, about a year ago the truck was at a trans shop and it got a new trans pan installed so idk if they would of been able to tell if anything was bad by just having the pan off . My friend i bought the truck off of said it always has done this since he owned it . Any ideas i really would like not to blow up my trans .
    2001 Gmc Sierra 2500hd
    -All clear lights with 5000k HID -Spectre cold air intake w/ k&n cone -Cooper dicoverer ST Maxx 285/75/16 -Meyer 7.5ft poly plow E60 pump - 3500 Rear springs-Leveling kit- Backrack-LED interior lights - Pioneer headunit with Alpine type s 6.5 and Polk 4x6 and 12 inch pioneer sub with alpine vpower amp.

  2. #2

    Default

    also i have no check engine light on .. if that helps any

  3. #3

    Default

    anyone else have the same problem?

  4. #4

    Default

    I found this in the p1870 thread.
    ........A harsh 1-2 shift or DTC P1870, caused by wear in the..."Control Valve Body", may be difficult to duplicate when the transmission temperature is below 93C (200F).


    Read more: http://www.gmtruckclub.com/forum/sho...#ixzz292V6VX7D

    This almost sounds like what your describing less the CEL trouble code. You may have read this already but it may just not quite be in range for the sensor to kick your CEL on. Also I have heard that this condition does exist beyond the years stated in this service bulletin. When I had my transmission rebuilt in my 03 Cadillac the transmission shop I took mine to told me this update was still being done to newer transmissions (the 4l60-E) Good luck!!





    2011 Silverado CrewCab 5.3L*Ram Air Look Cowl Induction Reflexxion Hood*6" Pro Comp Lift*Flowmaster Dual exhaust*Perfect Launch Rear Diff. Cover*Led Smoke Taillights*L.E.D.Smoke 3rd Brakelight*60" L.E.D. Tailgate Bar*Rearview Mirror Reverse Camera and Sensors*Smoke Headlight Covers*Front Bumper Grill Insert*Deezee Black Alum. Diamond Rail covers*20" Ultra Motorsports Rims wrapped with 35.5"B.F. Goodrich Tires*Inchannel Raingaurds*CAI*Bullydog GT Tuner*Alpine Amp*Boss 6x9's*Boston Acoustic Subs*Terrantula Tweeters*Custom Sub box*Red Led Interior Accents*5% Ultimacool duo tint rear window and doors, 20% front doors*Custom Vinyl Graphics*Demolded*Debadged*Painted drums and calipers*
    Future Mods Include: Custom Interior Hydrographics, Electronic Rollup Toneau Cover, 4.56 Gears, Painted rear bumper

  5. #5

    Default

    Thank you i read that thread but i wasnt too sure if it applied to my truck. i thought my truck has a 4l80e .. its a 2001 2500hd 6liter? this issue is really starting to piss me off .. to top it off my front diff axle seals are leaking :(

Similar Threads

  1. Replies: 16
    Last: 03-07-2012, 06:49 PM
  2. Replies: 8
    Last: 06-25-2011, 04:32 PM
  3. sudden trans issue
    By mikesk2500 in forum GM Powertrain
    Replies: 6
    Last: 12-18-2010, 02:23 PM
  4. Trans electrical(?) issue
    By bigdogdaddy in forum GM Powertrain
    Replies: 1
    Last: 05-28-2010, 03:20 PM
  5. Suburban trans issue
    By jernla in forum GM Powertrain
    Replies: 3
    Last: 01-04-2009, 01:49 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •