GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 4 of 4
  1. #1
    Jr. Apprentice
    Join Date
    Oct 2011
    Location
    South portland, Maine
    Posts
    23

    Default 97 K2500 Sub/ ABS light

    i searched this problem and came up with some things, but nothing seems just like mine. I have had an ongoing problem with the rear brakes locking up on rainy days until they got dried out. If I went down a hill when they were still sticking they would sometimes trigger the ABS and I have a had time stopping. But, other than those times everything seemed fine. Then the other day the ABS light came on and as I went down a slight hill and tried to come to a stop the ABS pump started. But, that was like 5 days ago and have not had another problem with the brakes. I have stomped on them and tried very light pedal stops, but they seem to work fine. Problem is the ABS light is still on. Also, went to Autozone to read the codes and they didn't come up with any. Any ideas before i head to the dealer next week???? Thanks

  2. #2
    Jr. Apprentice
    Join Date
    Oct 2011
    Location
    South portland, Maine
    Posts
    23

    Default

    Turned out to be a right front wheel sensor...

  3. #3

    Default

    Hi, longbeach

    Could you tell me how they determined which sensor was having the problem. I am having the same issue. Would sure like your input.

    Thank you and have a Great day.
    Chris - Laughlin, NV
    1997 GMC Suburban K2500 7.4


  4. #4
    Jr. Apprentice
    Join Date
    Oct 2011
    Location
    South portland, Maine
    Posts
    23

    Default

    Quote Originally Posted by racenrose View Post
    Hi, longbeach

    Could you tell me how they determined which sensor was having the problem. I am having the same issue. Would sure like your input.

    Thank you and have a Great day.
    Racenrose, I brought it to the dealership and they diagnosed it. But, I know there are clips on you tube about diagnosing this. I thin you disconnect the sensors and read the ohms, or something like that. The reason I took it to a dealer was because mine is a 3/4 ton and you have to take the whole wheel hub apart, if you have a half ton it is a lot simpler.Good luck

Similar Threads

  1. Replies: 0
    Last Post: 02-20-2012, 12:40 PM
  2. Tail Light/ Head Light Smoked Tint Finally pulled the trigger for $40!
    By Rockstarrchevy81 in forum Chevy Truck Accessories
    Replies: 8
    Last Post: 09-24-2011, 01:47 PM
  3. 99 Tahoe weird tail light/brake light/hazard light/blinker problem NEED HELP
    By beckya99 in forum Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)
    Replies: 0
    Last Post: 07-11-2011, 10:46 AM
  4. 95 k2500
    By simpmech in forum Lifted & Offroad Suspension
    Replies: 3
    Last Post: 03-02-2011, 07:14 PM
  5. 99 K2500 4x4 , LT with the 454
    By Surfer2001 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 0
    Last Post: 03-19-2009, 07:21 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •