GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 5 of 5
  1. #1

    Lightbulb 95 Suburban either missing, or fuel cuts out.

    First of all let me state that this does not happen when it is really cold outside, below 20 degrees. But when i am moving down the freeway, it runs fine, except that it seems that it the engine is cutting out, as it pos and sometimes sputers especially when it is starting to excelerate, but it also seems to have small cut outs just cruising, and will try to cut out from a complete stop. I have replaced everything fuel related, except the fuel pump, and have been told that it could be the temperature sensor right next to where the thermosat is on top of the engine, and it could be telling the computer that it is 20 below zero, would it be prudent to change this, or would anyone have anyother suggestions. it runs great except for that little problem
    Last edited by pook7one; 01-07-2008 at 03:32 PM.

  2. #2

    Default

    If it is your fuel pump,, I don't think you would be able to do a hard acceleration. Sounds like the symtoms are a little on the sporatic side. electric?
    Jay :happy: Waxhaw, N.C.
    70 Chevy C-10 Stepside from 86 lowered 2" front 3" back, 383ci/350hp. elec. seats,functioning cowl, wood bed, hidden hitch, hidden tach, long headers, duel 3" exhaust. perform int., semi-aggressive cam (no specs.)
    69 Chevy C-10 Fleetside 350 ci 3spd. mild cam, 270hp,stock.duel 2.5" exhaust. Lowered 2" made own blocks

    89 Ski Marlin Boat 350 ci:party: pulling machine. 7 skiiers.

  3. #3

    Default mabye

    I have thought that i might have to change the plugs and wires, I have alredy replaced th ICM, and the rotor and the cap.

  4. #4

    Default

    My guess would be ignition module, if this has a distributor it’s under the cap. If this has a coil pack, it’s under the coils.

    Under the distributor it’s a part costing less than 50 bucks.

    If it’s a coil pack it is very expensive.


    The module in our 94 went and then worked, then went and then worked, they can be quirky.

    There is a test procedure but I can’t remember it.

    Technology is great, when it Works,
    And one Big Pain in the Ass When it Doesn’t.
    Detroit Iron Rules, All the Rest are Just Toys.
    94 GMC Burban, 5.7L (350), 4X4, Auto
    86 GMC Burban, 350, 2 WD, Auto
    79 GMC pickup plow truck, 400, Full time 4X4, Auto
    86 Pontiac Fiero SE, 2.8L, Auto, only mid engine American car
    See a Pattern yet?

    15 year GM assembly line worker.

  5. #5

    Default

    tahnk you for the insight, I replaced my plugs and wires, and it runs better now than it did when i bought it 2 years ago. now i can install my E85 conversion into it

Similar Threads

  1. 93 suburban tbi fuel problem need help
    By 93 lo'burban in forum GM Powertrain
    Replies: 1
    Last Post: 12-27-2009, 08:16 PM
  2. 99 c1500 5.7 suburban missing at idle when hot
    By i_build in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 3
    Last Post: 10-22-2009, 06:08 PM
  3. 99 Suburban radio cuts out
    By carmental in forum Audio, Video & Gadget Tech
    Replies: 4
    Last Post: 05-25-2009, 06:43 PM
  4. Need some help on 03 Suburban fuel system
    By cj428mach in forum Performance & Fuel
    Replies: 0
    Last Post: 03-01-2009, 11:24 AM
  5. 1996 GMC Suburban 5.7L Cuts Out/Off
    By kirk.toune in forum GM Powertrain
    Replies: 5
    Last Post: 01-26-2008, 09:37 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •