GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 2 12 Last Post byLast Post by
Results 1 to 10 of 11
  1. #1
    Jr. Engineer
    Join Date
    Dec 2008
    Location
    south florida
    Posts
    239

    Default A/C irratic function

    guys
    i have a 1990 k1500 4x4 with 5.7 engine.
    sometimes, in the past, with the a/c on, it would blow about 50% out of the vents, and the other 50% either out of the dash or down by the trans tunnel. i would hit on the lower unit, and the (flap) would close and it would them blow 100% out of the vents.
    but now its doing something different. its blowing about 25% out of the vents, and i can hear the blower blowing, like deep inside somewhere, but nothing is coming out from the trans tunnel vent or the defrost..
    what is going on here ? anyone have this happen to them before ? cant figure this new problem out.
    thanks guys

  2. #2

    Default

    The air is diverted using doors (mode doors), you may have one sticking.

    The newer trucks use electric motors, before that, the motors were operated by vacuum, I don't know when they changed over

    Try searching the site for mode doors
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

  3. #3
    Jr. Engineer
    Join Date
    Dec 2008
    Location
    south florida
    Posts
    239

    Default

    thanks much.. i will search for "mode doors", when i get home from work..

  4. #4

    Default

    I've done both the passenger and driver's side actuator replacements on my 2004. Sadly I have no clue if that knowledge translates/transfers to a 1990 K1500. :(

  5. #5
    Jr. Engineer
    Join Date
    Dec 2008
    Location
    south florida
    Posts
    239

    Default

    OK guys,
    after searching on here and the internet, yes, it seems as if the mode door actuator is my problem.... it really only pops up every few months or so, but i think i will replace it anyways, since it is so easy to access....
    thanks guys

  6. #6
    Jr. Engineer
    Join Date
    Dec 2008
    Location
    south florida
    Posts
    239

    Default

    Quote Originally Posted by SurrealOne View Post
    I've done both the passenger and driver's side actuator replacements on my 2004. Sadly I have no clue if that knowledge translates/transfers to a 1990 K1500. :(

    ok guys, it was good all week, and acted up today again.
    earlier in the week, i marked the actuator thats over the trans tunnel, on the left side of the box. i marked it when it was all working fine, blowing 100% out of only the vents.
    today when it was acting up, blowing less than 50% out of the vents, but nothing out of the defrost or lower trans tunnel opening, for the heat, i looked at my marks and that actuator is opening in the same position as when it was working fine, so it cant be that actuator.
    i found a drawing and see there is a "temperature actuator" thats located in the middle of the unit. could that be my problem ?
    on that drawing it does not show a right side actuator, mounted right next the the blower motor, on the passengers side...
    what does that actuator do ? again, my drawing i found online doesnt show that actuator.
    the cooling system is working fine, dripping a lot of condensed water through the drain tube and onto the ground.
    its driving me crazy....... please help.
    thanks guys

  7. #7

    Default

    I wish I knew how to help you, but my knowledge is limited to the 99-06 (and 07 classic) years, as that's what I own and have worked on. :(

  8. #8
    Jr. Engineer
    Join Date
    Dec 2008
    Location
    south florida
    Posts
    239

    Default

    guys, i have found this diagram

    http://www.gmtruckclub.com/forum/sho...#axzz29P2WmsOD

    view "C", #62, recirculation actuator, could this maybe be my problem ?
    maybe sticking between two modes ?

    thanks

  9. #9
    Jr. Engineer
    Join Date
    Dec 2008
    Location
    south florida
    Posts
    239

    Default

    ok guys,
    i laid up under the passengers side dash today and that actuator really looks like a pain to change out. no room to get at the screws. i have marked the position its at when its working correctly, so next time it acts up, i will see where the shaft is in relation to my mark.
    also i figured out that the next time it does act up, i will try cycling it through the three positions of defrost, vents, and lower trans tunnel vent, to see it i can "un-stick" it and get it blowing through only the vents.
    just dont want to change it out, since its so hard to get to.
    thanks

  10. #10

    Default

    Quote Originally Posted by RATRODKING View Post

    view "C", #62, recirculation actuator, could this maybe be my problem ?
    maybe sticking between two modes ?

    thanks
    Recirc is the function that switches between inside air and outside air. When recirc is on, the inside air is recirculated through the heater/ac vents. when recirc is off, outside air is drawn into the vehicle.

Page 1 of 2 12 Last Post byLast Post by

Similar Threads

  1. 1996 Tahoe irratic misfire at idle, runs fine off idle and cruise
    By tankdg1 in forum Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)
    Replies: 1
    Last: 09-17-2011, 06:11 PM
  2. Multi-function switch
    By stevers in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 3
    Last: 01-04-2011, 02:25 PM
  3. How does the auto 4wd function
    By dabel in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 3
    Last: 12-30-2010, 08:52 AM
  4. Headlights function
    By cdvntx in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 6
    Last: 06-04-2010, 10:37 PM
  5. tow/ haul function
    By henrys021500hd in forum General Chevy & GM Tech Questions
    Replies: 1
    Last: 08-19-2009, 09:24 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •