GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 8 of 8
  1. #1

    Default Need help, 1995 K1500 will just not start

    1995 K1500, 5.7 V8

    The truck will just not start. Drove to work one day, ran fine. Went to leave and it would just turn and not start. Changed the nuetral safety switch as a recommendation from friend, and it fired right up. Drove it a couple days, and then same thing happened. Tried it the next day and fired right up. This happened about 5 times, so I parked it thinking it was the fuel pump going bad.

    Fast forward 3 months to 2 days ago. Went out and tried to start, same thing. Jiggles some wires, poked around, took the air filter off, and it started right up. Drove around for a few minutes, and it ran fine. Pulling back into the yard, I floored it a couple times from idle and it would die or almost die, then it'd recatch and idle fine. Turned it off, turned the key and it fired right up. Tested it about 4 times, and each time it fired right up. Let it sit for about 4-5 hours, went to turn the key and it just turned but didn't start. Haven't got it started since.

    Yesterday, changed out fuel pump, filter, and threw all new plugs on. Still won't start. Just turn. Give it a shot of starter fluid and it stumbles, but won't acutally fire up and run.

    Today, changed the Ignition control module, distributor cap, rotor cap and still doing the same thing.

    My guess is it's something fuel realated since it will attempt to start with the shot of starter fluid, but not really sure.


    Any guesses? Bad battery, fuel pump relay, bad ignition control module, bad fuel injector?

    Please help

    -Josh
    Last edited by SpeedoJosh; 10-22-2012 at 08:35 PM.

  2. #2

    Default

    Ok, I had a bit of a problem following the current status, considering your "fast forward" comment.

    So as of right now, after having changed out the fuel pump, filter, plugs ... it still won't start up. Oh, you did ignition control module and all of that too ...

    How many miles on this? Do the electronics work otherwise and are any codes being thrown?

    Steve
    10 Chevy Traverse LT AWD
    02 Chevy Trailblazer LS (110K+ miles - loaded except for 4WD - WRECKED!)
    99 Chevy Cavalier LS (105K+ miles - commuter car)
    78 Chevy Suburban Silverado (454, 3/4 ton)
    62 GMC 3/4 ton Pickup (350 police interceptor)

    Remember: Search Before Posting | Fill out Your Profile & Signature
    Follow Us Please: facebook.com/gmtruckclub | twitter.com/gmtruckclub
    Support GMTC: Help the site, contribute today

  3. #3

    Default

    All electroics are working well. The gear indicator light doesn't work in P or D.

    140,000 miles

  4. #4

    Default

    Put a new battery on it today, and it fired right up. Drove it around for a couple minutes. Turned it off, turned it back on, it fired right up. Let it sit for about 30 minutes, went to go start it again, and it wouldn't start. Just turn and turn, but wouldn't start.

    This is driving me crazy

  5. #5

    Default

    do you have a security light on? i had a random problem with a crank/sputter,no start when it was humid out. turns out it was a security issue....no idea how but i left the key in the ignition, in the on position...let it sit 10 minutes and it reset the security. started right up

  6. #6

    Default

    No security light.

    I'm thinking it has to be something electrical. Truck will just turn and turn and not fire. Then I'll walk out there randomly, wiggle a couple wires and it will fire right up. I can drive it fine, turn it off and right back on as many times as I want. Then let it sit for 15 minutes then it will just turn and turn.

    I keep hearing people say they can see fuel spraying from the injectors. Can I see this when the engine is just turning and turning?

  7. #7
    Sr. Apprentice
    Join Date
    Oct 2008
    Location
    Peoples Republic of Kalifornia
    Posts
    36

    Default

    If you have an aftermarket burglar alarm check the connections, and function This drove me crazy on my truck, until I traced it to a short in the alarm system. BTW, the system that I had was a Pro-Lok.
    1993 K-2500 Suburban Silverado, 7.4L, 4 X 4, HD Towing
    1985 Jeep Scrambler 4.2 L, 4 X 4, Laredo
    2005 Dodge Dakota, 4.7L, 4 x 4,, TRX4, SLT

  8. #8

    Default

    Quote Originally Posted by SpeedoJosh View Post
    I keep hearing people say they can see fuel spraying from the injectors. Can I see this when the engine is just turning and turning?
    Yes. It should be "spitting" fuel out of the two injectors when you try to start the truck. Take off the air filter housing and have someone try to start it when its in the no start condition. You should be able to see fuel coming out.

Similar Threads

  1. 1995 K1500 dies out
    By eddiestrysik in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 0
    Last Post: 06-08-2012, 01:23 PM
  2. 1995 chevy k1500
    By ossumpanda in forum Chevy C/K Truck Forum
    Replies: 2
    Last Post: 12-27-2011, 10:54 AM
  3. upgrade frontbrakes K1500 1995
    By 2loud in forum Lifted & Offroad Suspension
    Replies: 0
    Last Post: 04-20-2011, 07:24 AM
  4. 1995 GMC K1500 5.7 running rough
    By tknucks in forum GM Powertrain
    Replies: 2
    Last Post: 02-03-2011, 01:55 PM
  5. Parting out 1995 k1500 suburban
    By skinut88 in forum General Classifieds
    Replies: 8
    Last Post: 01-25-2010, 11:01 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •