GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 6 of 6
  1. #1

    Default 1997 Burb... Dies.. then won't start for 20 minutes

    1997 Suburban C1500 350 Vortec.

    It will start in the morning fine.. drive for a few miles then just die. If it sits for a few minutes it will start back up. Drive for a mile then dies. Now I have to wait 20 minutes... then is will start again.. Repeat.

    I can hear the Fuel pump, and if it sicks overnight or just for an hour it will start right back up no problems, good idle.

    At one point the CIL came on. I checked the code, came up as MAF sesnor. The CIL went off and never came back on.

    When it is running it isn't lacking any power or showing signs of fuel starvation.

    I tried changing the MAF sensor just to be safe.. It didn't make a difference.

    Someone suggested pulling the Ignition Module and have it tested. I have removed it and will be having it tested at least 5 times after work today. I want to make sure they can build some hear in the module.

    Anyone have any experience with the problem that can maybe lead me to where I can look.


    Big D

  2. #2

    Default

    Certainly sounds electrical in nature.

    After changing the MAF, did you clear the MAF code from the computer's memory? If you did, is it coming back with the MAF code still, another code, or pass? Remember that codes point to problems in circuits, of which the sensor is only part. If your MAF code is consistently coming back, you probably need to look at the rest of the MAF circuit between the PCM and the MAF. It also might be time to take a trip to the library to get the official diagnostic procedures for the specific MAF code you are getting.

    Even though you can hear the fuel pump, I would probably put a fuel pressure gauge on the fuel line to make sure you are getting the correct fuel pressure. It might also be useful to verify that the fuel injectors are opening to let fuel into the cylinders. Of course, because it is intermittent, these all need to be checked when the engine is stalling/not starting.

    Let us know how the ICM checks out.
    '98 K1500 Suburban LS 5.7 L 4L60E NV246 ARB
    '92 Ford Explorer XLT 4x4 4.0 L A4LD BW13-54 Trac-loc rear
    "My toys were the greasy cogs and springs and pistons that lay around all over the place, and these, I can promise you, were far more fun to play with than most of the plastic rubbish children are given nowadays." Danny in Roald Dahl's Danny The Champion of the World

  3. #3

    Default

    Quote Originally Posted by MrShorty View Post
    Certainly sounds electrical in nature.

    After changing the MAF, did you clear the MAF code from the computer's memory? If you did, is it coming back with the MAF code still, another code, or pass? Remember that codes point to problems in circuits, of which the sensor is only part. If your MAF code is consistently coming back, you probably need to look at the rest of the MAF circuit between the PCM and the MAF. It also might be time to take a trip to the library to get the official diagnostic procedures for the specific MAF code you are getting.

    Even though you can hear the fuel pump, I would probably put a fuel pressure gauge on the fuel line to make sure you are getting the correct fuel pressure. It might also be useful to verify that the fuel injectors are opening to let fuel into the cylinders. Of course, because it is intermittent, these all need to be checked when the engine is stalling/not starting.

    Let us know how the ICM checks out.

    I'll let you know, I hope that it is the ICM. FYI Though, the Fuel Pump, Pick up, socks, and Fuel Filter were all changed less than 6 months ago. The CIL has never came back on, just that once.

    Thanks,

    Big D

  4. #4

    Default

    Could it also be heat related? Putting it out there. no need to answer.
    Jay :happy: Waxhaw, N.C.
    70 Chevy C-10 Stepside from 86 lowered 2" front 3" back, 383ci/350hp. elec. seats,functioning cowl, wood bed, hidden hitch, hidden tach, long headers, duel 3" exhaust. perform int., semi-aggressive cam (no specs.)
    69 Chevy C-10 Fleetside 350 ci 3spd. mild cam, 270hp,stock.duel 2.5" exhaust. Lowered 2" made own blocks

    89 Ski Marlin Boat 350 ci:party: pulling machine. 7 skiiers.

  5. #5

    Default

    The ICM checked out as good.. Passed six times. What next??

  6. #6

    Default

    Is it bitter cold where you are? If so, maybe frozen fuel line.


    If not carry an squirt-type oil can with gas in it. The next time it happens, open the hood, remove air filter cover, and spray air filter with gas(no need to remove air filter). If it starts up then you know it's a fuel problem. If it doesn't, pull a spark plug. Not enjoyable to do on the road though. What happens if you let it run outside?
    01 Suburban 2500 LT 4X4, 8.1L
    95 Taurus SHO, 80K, 5 sp, many mods

Similar Threads

  1. 95 GMC Burb - Hard Start/Rough Idle
    By Crispy3M in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 3
    Last: 09-15-2009, 10:38 PM
  2. AAACK! - '97 Burb, 5.7L suddenly "No Start"
    By Applegeek in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 20
    Last: 02-09-2009, 10:55 AM
  3. 1997 k2500 Burb 5.7l - Very rough when cold
    By Applegeek in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 2
    Last: 10-30-2008, 10:52 PM
  4. 97 Burb wont start - Heavy Crank
    By chargerrich in forum GM Powertrain
    Replies: 3
    Last: 03-02-2008, 08:52 PM
  5. 1997 Silerado ....5.7 vortec . Wont start when cold
    By qpe05 in forum GM Powertrain
    Replies: 7
    Last: 09-05-2007, 03:22 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •