GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 2 12 Last Post byLast Post by
Results 1 to 10 of 12
  1. #1

    Question Tail Lights not working!!

    i have a 2007 silverado classic, and my brake lights have stopped working. i checked all the fuses and they are all ok. the third brake light still works, and i know its not just bad light bulbs cause the blinker still works. i even tried chaning the bulb to see if just the brake light filament was bad and that did nothing. im thinking it might be the brake switch relay but im not to sure.
    Last edited by dodger32; 03-10-2011 at 05:20 PM.

  2. #2
    Legend
    stephan's Avatar
    Join Date
    Sep 2010
    Location
    Far West, Oregon USA,
    Posts
    8,610
    Blog Entries
    1

    Default

    Your title says tail lights but in your text body it says both brake lights & tail lights. Which are we working with here??
    1988 Chevy C-3500 2wd (no pic)
    350 c.i. 5.7 L Stock Block, 4 Bolt Mains
    L-31 Vortec Heads, Edelbrock Cam & Intake,
    Holley 650, Flowtech Headers, Magnaflow exh.
    Jet Trans 700R4, B&M Ratchet, 4:10 gears,
    3" susp. lift kit "shadetree"
    No rev limiter, No speed limiter lol


  3. #3

    Default

    sorry about that. it is the brake lights that are not working

  4. #4
    Legend
    stephan's Avatar
    Join Date
    Sep 2010
    Location
    Far West, Oregon USA,
    Posts
    8,610
    Blog Entries
    1

    Default

    Ok a good place to start would be to have a helper step on the brake pedal while you check for power at the sockets with a volt meter or a test light. Do you know if they both quit working at the same time, or did one go out some time before the other? There has been talk on here about the circuit boards going bad. :-(

  5. #5

    Default

    The left went out first then the right

  6. #6
    Legend
    stephan's Avatar
    Join Date
    Sep 2010
    Location
    Far West, Oregon USA,
    Posts
    8,610
    Blog Entries
    1

    Default

    OK this sounds like the individual circuit boards then. If this had a common link, they would have both quit at the same time. Go ahead with your power test at the sockets. If no power there, then check for power into the boards. If you have power in, then the boards are bad. This could also be a corrosion problem. Did you see any when you were changing the bulbs out?

  7. #7

    Default

    Did you fix this? I just lost my brake lights. The third brake light works. Where is the board you are talking about? Anyone know where the wiring diagram is for this?

  8. #8

    Default

    If the 3rd works, the brake light switch is good, the main fuse feeding the switch is good.

    You didn't provide vehicle info, but you probably have a fuse for the wires going to the rear light sockets, check it.

    Have you checked the bulbs, like your house lights, it is usually the bulb that goes first.
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

  9. #9

    Default

    I'm going to replace both bulbs first thing, but I kinda doubt they would both go out at the same time.. Of course one could have been out for a while.

  10. #10
    Legend

    Join Date
    Sep 2010
    Location
    everett, massachusetts
    Posts
    1,468

    Default

    I would hold the brake pedal down [use a piece of wood] then with a meter find the loss of voltage/grounds to the rear brake lamps.
    Last edited by j cat; 10-28-2012 at 11:00 AM.

Page 1 of 2 12 Last Post byLast Post by

Similar Threads

  1. 04 Tahoe Rear tail lights not working
    By bulldawg06 in forum General Chevy & GM Tech Questions
    Replies: 5
    Last: 11-25-2012, 02:03 AM
  2. 82 K10 Tail and Reverse Lights Not Working!
    By ahobson1 in forum Chevy C/K Truck Forum
    Replies: 7
    Last: 06-20-2010, 08:08 PM
  3. Tail lights not working
    By carlsauction in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 7
    Last: 05-28-2010, 08:39 PM
  4. Rear tail lights not working
    By floutlaws in forum General Chevy & GM Tech Questions
    Replies: 7
    Last: 08-22-2009, 10:21 AM
  5. Trading My Stock Tail Lights for Euro Tail Lights
    By ippielb in forum Chevy Truck Accessories
    Replies: 5
    Last: 07-10-2009, 11:50 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •