GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 6 of 6
  1. #1

    Default need help with my truck

    hello all i need help with my 1975 Chevy Custom Deluxe 10 i just bought a new battery for it last week and went i hooked up the battery i hooked it up wrong and now my truck will roll over but it wont start and sometimes it sounds like the battery is dead but when I turn the lights on they are bright it has the 250 inline 6 with 511.000 miles on it and would really like to get this truck running again i have changed the wire from the starter to the firewall and still nothing any help would be great thanks for you time

  2. #2

    Default

    Check the points, or if someone converted it to electronic ignition check the ignition module. If they converted to electronic ignition depending on the kit they used the module will be either on the fender or under the distributer cap.
    I also sounds like you might have fried a ground wire too, check the power cables at the starter.
    These older electronics arent as forgiving when you piss them off.

  3. #3

    Default

    ok an update i have put a new starter in new ground wires all them now truck in not rolling over at all not even a noise coming from the starter or solanoid not sure what to do now could it be the positive battery cable or is there a relay some where that im not seeing and all the inline fuses are gone now there is a purple wire that goes from the starter to the harness would that be an issue aswell any help would be great would like to see this old girl running again cheers

  4. #4

    Default

    Look, I'm not trying to cut you down here, but please speak clearly. I'm having a lot of trouble understanding your post, because it's a massive run-on sentence.
    ...
    ....

  5. #5

    Default

    hey its ok i get like that when im tired but i have got it figured out had truck running lastnight its my battery that is giving me the problems now. Once again sorry for going on like that but with no sleep and getting stressed out with the truck my brain never stops but anyways thanks for all the help cheers

  6. #6

    Default

    I take it you shorted out the battery too?
    Good to hear you got her running again.

Similar Threads

  1. Replies: 0
    Last: 07-19-2011, 01:00 AM
  2. Replies: 1
    Last: 03-23-2011, 09:28 PM
  3. Replies: 0
    Last: 03-12-2011, 08:10 PM
  4. Chevrolet Rat Truck 1936 CHEVY RAT TRUCK, BRAND NEW, SHOW TRUCK, ONE-OFF.
    By ChevyFan in forum Chevy Trucks For Sale eBay
    Replies: 0
    Last: 11-14-2010, 07:50 PM
  5. Replies: 0
    Last: 11-19-2009, 12:10 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •