GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 10 of 10

Thread: speaker help

  1. #1

    Default speaker help

    hey guys,
    ive had a set of boston 6.5 components in my truck since my older brother gave it to me a while back, i wanna say theyre probably around 7 years old, but they sound amazing for their age i think. anyway i recently went from a 45W*4 (4 ohms) amp to a 110W*4 (4 ohms) amp (RMS) and noticed a change...
    With my weaker amp, ever since i had the truck, after playing real loud for about 2 minutes or so, it would seem like i lose a whole range of music, like most treble cuts out or something just drops out of range... if i turn the volume down, it comes back (basically if i let the speakers rest) now with this bigger amp if i turn it up real loud they do the same thing but in about 10 seconds...
    what does this mean? a coil heating up too hot? too much power? I, at one time, found specs for these speakers, but no longer can due to their age, but i remember when i found them about a year ago, i still saw sets going for about $200.00, i really wish i could find the specs on them but can never find them no matter how much i google about them.
    Just wondering what causes this sort of "audio cutout"? so to speak, at high levels of play.
    thanks
    2000 Chevrolet Silverado

    Powertrain:
    4.3L V6, 4L60E, 2WD, Single Cab
    Performance:
    Airaid CAI
    Poweraid TB Spacer
    Flowmaster 10-series exhaust (dumped)
    BLACKBEAR TUNED!!!
    Edge CS insight monitor
    4.10 gears
    Limited-slip differential
    LS-1 Dual Electric fans
    Corvette tranny servo swap

    Audio:
    Head Unit: Alpine
    Speakers: Alpine SPR-60C 6.5" component set, 4X6 Infinity Kappas
    Subs: 2-12" Kicker CVT's
    Amps: Alpine-M1000 (subs), Alpine MRX-F65 (Speakers)


    Tires/Wheels:
    305/70R16 NITTO Terra Grapplers
    16" PROCOMP 7089's
    Suspension:
    2" leveling kit
    3" Fabtech Spindle Lift Kit
    Front/Rear-Bilstein 5100 shocks

    Lighting:
    FRONT
    35W HID Low Beams
    RECON LED smoked roof cab lights
    REAR
    HELLA LED taillights and 3rd brakelight
    HELLA FF-75 Aux. Reverse Lamps
    RIGID dually D2, flush mount, wide beam
    Accessories:
    Hawk HPS Brake pads
    Russell braided steel brake lines
    Powerstop-red powdercoated brake calipers
    Powerslot Cryo brake rotors
    EGR in-channel window visors

  2. #2

    Default

    How bizarre. I've never experienced that so you've got me stumped. Resistance-related, maybe? I'm curious what @Enkeiavalanche or @zigger215 have to say on the subject...

  3. #3
    Master Mechanic zigger215's Avatar
    Join Date
    Sep 2011
    Location
    Fairbanks, Alaska
    Posts
    551

    Default

    I'm back! After a very long absence lol. What's up surreal? I got your pm but September has come and gone...

    Anyways, to the OP. it sounds like your speakers have simple just aged. Speakers do have a "shelf life" so to speak and it appears yours have reached the end of the line. The distortion your talking about is fairly common among older systems, 7 years is fairly old for a set of Boston components. The reason you are distorting faster with a bigger amp is simple that. It's pushing even MORE power to speakers who couldn't handle the original power. (I understand at one point they probably could have when they were newer).

    Pop your door panels off and inspect the speakers for any corrosion (on the copper leads) or cracks in the cone or surround.

  4. #4

    Default

    Quote Originally Posted by zigger215 View Post
    I'm back! After a very long absence lol. What's up surreal? I got your pm but September has come and gone...
    Welcome back!

  5. #5

    Default

    Quote Originally Posted by zigger215 View Post
    I'm back! After a very long absence lol. What's up surreal? I got your pm but September has come and gone...

    Anyways, to the OP. it sounds like your speakers have simple just aged. Speakers do have a "shelf life" so to speak and it appears yours have reached the end of the line. The distortion your talking about is fairly common among older systems, 7 years is fairly old for a set of Boston components. The reason you are distorting faster with a bigger amp is simple that. It's pushing even MORE power to speakers who couldn't handle the original power. (I understand at one point they probably could have when they were newer).

    Pop your door panels off and inspect the speakers for any corrosion (on the copper leads) or cracks in the cone or surround.
    ive inspected them before a couple times and they appear in near perfect cosmetic condition, no rust or corrosion, i was astonished for how old they are, but also at the same time i wouldnt think for these being a POSSIBLY "high end" speaker setup my older brother put in, that they would not be able to even handle 45X4 RMS(@ 14.4V of course), so as you say, AGE may just be a possible culprit here, if nothing else...

  6. #6
    Master Mechanic zigger215's Avatar
    Join Date
    Sep 2011
    Location
    Fairbanks, Alaska
    Posts
    551

    Default

    Age is a major culprit for sure. I wear out 600 dollar pairs of components in months from demoing lol, time under power determines the age of a component, it's natural that someone who listens to their music loud will wear out their components quicker.

  7. #7

    Default

    well, this is lower on my priority list for now, as surreal knows, from my other threads, just trying to gather from possible culprits, which it seems ive found LOL...
    but the next component set ive been aiming at is the alpine type-R 6.5 component set, have always heard good things, and their type-R line has always sounded great to me from the few setups i have heard in friends cars...

  8. #8

    Default

    Those speakers have built-in clips. When you overdrive the speaker, the unit has a trip that enacts a filter to cut that freq range to protect the speaker. Once the amplitute returns to normal after a minute or so of sustained input, then the clip drains (releases) and you get your full sound range back. The clip ranges are Low, Mid, Treble on 3-ways. Low to midline mid and midline mid to high for 2-ways.

    My Technics home speakers have them. Boston's are high end stuff, I wouldn't doubt they have this considering the age you state. They don't do this today because companies don't care if you blow your speakers unfortunately.

    I think your overdriving your speakers so you will either have to adjust or control the urge to crank too much or change to a higher rated speaker I think. They are nice speakers.

    Send me the info on those speakers if you want. Guy across the street is a professional Audio and Alarm installer. I can see if he could obtain this info for you if you like. I'm thiking you got too much for those speakers.
    '13 Silverado 2500 | Crew Cab 2WD W/T | Vortec 6.0 | Diablew Tune |
    (Various Chrome items & Bestop Tonneau...)



  9. #9
    Master Mechanic zigger215's Avatar
    Join Date
    Sep 2011
    Location
    Fairbanks, Alaska
    Posts
    551

    Default

    Type-R speakers sound good to my ears as well. I wouldn't think you would be going wrong running type-Rs.

    A 200 dollar pair of Boston acoustics speakers are not considered high end and most likely do not have a "clip". My competition QS (built a few months ago) do indeed have a similar style clipped coil. They are still around but you only see them in high end speakers for mobile electronics.

  10. #10

    Default

    Quote Originally Posted by awtposts View Post
    Those speakers have built-in clips. When you overdrive the speaker, the unit has a trip that enacts a filter to cut that freq range to protect the speaker. Once the amplitute returns to normal after a minute or so of sustained input, then the clip drains (releases) and you get your full sound range back. The clip ranges are Low, Mid, Treble on 3-ways. Low to midline mid and midline mid to high for 2-ways.

    My Technics home speakers have them. Boston's are high end stuff, I wouldn't doubt they have this considering the age you state. They don't do this today because companies don't care if you blow your speakers unfortunately.

    I think your overdriving your speakers so you will either have to adjust or control the urge to crank too much or change to a higher rated speaker I think. They are nice speakers.

    Send me the info on those speakers if you want. Guy across the street is a professional Audio and Alarm installer. I can see if he could obtain this info for you if you like. I'm thiking you got too much for those speakers.
    wow, thats interesting to know!, ill try and pop my door panel off and get the name of the speaker when i get a chance

Similar Threads

  1. Speaker Box
    By ScubaSteveo in forum Audio, Video & Gadget Tech
    Replies: 1
    Last Post: 11-21-2010, 07:16 PM
  2. PA speaker set up
    By Chaser1 in forum Audio, Video & Gadget Tech
    Replies: 8
    Last Post: 08-28-2009, 09:13 AM
  3. New Speaker Box
    By dutzowmo in forum Audio, Video & Gadget Tech
    Replies: 26
    Last Post: 06-03-2009, 11:29 AM
  4. speaker ?'s
    By capt sensible in forum Audio, Video & Gadget Tech
    Replies: 7
    Last Post: 04-25-2009, 07:17 AM
  5. Speaker Box
    By bzboardco in forum Audio, Video & Gadget Tech
    Replies: 13
    Last Post: 11-14-2008, 07:30 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •