GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 2 of 2
  1. #1

    Default MUST READ major electrical hazard ....

    I copied and pasted this hope it is ok, but i feel it is very important



    - - - Updated - - -

    Originally Posted by renegade1957
    I think i might have lost part of the ecm? Is that possible? It all started while going down the highway at 60mph and the sel and abs brake light flashed rapidly and engine felt like it died, then smoothed out again and the sel and park brake lights were no longer on.(they should be on because of o2 sensor code and park brake is set to 1 click to keep headlights off). since that episode the idle wont kick up for start unless the engine is stone cold. no stored codes, as if it shorted out and cleared itself out. all the lights on dash will light up with key on as usual, but not while running. help anyone?





    While under the hood, testing the temp sensor trying to get an ohm reading, with key off, i suddenly see sparks, smoke, and arcing sounds from lower engine passenger side!!!! wow! grabbed a wrench, pulled off the pos batt cable and climbed under to investigate this new issue. there is a heat shield on the starter that had rubbed its way through the starter cable and was shorting to the shield. I now realize that this is the culprit for these issues i have been having. explains the intermittent static i was getting on the radio too. I now believe that the ecm was getting stray voltage on the ground side and could not sort it out. May have partially fried the ecm, but it starts great now. I believe i was about a half hour from having a GMC bonfire in my driveway!! Next time you are under your truck, might be prudent to check this area out.



  2. #2

    Default

    This is a duplicate thread ... read my comments on the OT (original thread) and break your content down into smaller paragraphs and you will get more responses.

    Steve
    10 Chevy Traverse LT AWD
    02 Chevy Trailblazer LS (110K+ miles - loaded except for 4WD - WRECKED!)
    99 Chevy Cavalier LS (105K+ miles - commuter car)
    78 Chevy Suburban Silverado (454, 3/4 ton)
    62 GMC 3/4 ton Pickup (350 police interceptor)

    Remember: Search Before Posting | Fill out Your Profile & Signature
    Follow Us Please: facebook.com/gmtruckclub | twitter.com/gmtruckclub
    Support GMTC: Help the site, contribute today

Similar Threads

  1. HEEEEELP! 2000 Silverado has a major electrical issue!
    By Jimmeh in forum GM Electrical Tech
    Replies: 5
    Last Post: 09-13-2012, 07:33 PM
  2. 05 tahoe hazard lamp relay
    By nw3dogs in forum General Chevy & GM Tech Questions
    Replies: 0
    Last Post: 12-29-2009, 11:03 AM
  3. Major Electrical Outage in 04 Tahoe
    By Craig789 in forum Audio, Video & Gadget Tech
    Replies: 3
    Last Post: 07-16-2009, 03:41 PM
  4. major electrical issues, stalling, flashing lights, cruise malfunctions.... help?
    By kawasaki_kid in forum General Chevy & GM Tech Questions
    Replies: 4
    Last Post: 05-20-2009, 07:10 AM
  5. Hazard Light ?'s
    By KimH in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 2
    Last Post: 04-20-2009, 12:57 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •