GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 7 of 7

Thread: Not blowing hot

  1. #1

    Angry Not blowing hot

    This past weekend I drained the coolant out of my raidiator and refilled it using the correct proceedure, and now my heater only blows hot for a few seconds then goes cold!
    Anyone know what the problem could be?
    2003 Chevy 1500 5.3l VORTEC

  2. #2

    Default

    Quote Originally Posted by 2003-5.3-V8 View Post
    This past weekend I drained the coolant out of my raidiator and refilled it using the correct proceedure, and now my heater only blows hot for a few seconds then goes cold!
    Anyone know what the problem could be?

    yes you have air in the system and it is sitting in your heater core and you need to get the air out.

    is your overflow reading max at cold?

    when you start the truck does the level drop when running?


    you could try driving the car a short distance and then carefully releasing the pressure to burp the system of extra air. Given it is a closed system, you need to get the air out some how. Drive, burp, and add more coolant if you need to and it should work itself out.
    1995 Saturn Sw1 196K and counting
    2001 Suburban LS 150K and counting
    2004 MR2 Spyder 62K and counting
    2007 mini cooper S 60K and counting

  3. #3

    Default

    Hello,
    I think you have air in the system, too.
    You should start the Engine, open the cover of the water reservoir and start your heater-->the same time you fill up the reservoir with your coolant.
    Have you an expansion tank?
    Allway watch up, if you open the cover of the hot coolant!!!

    but it can be the thermostat, too!
    If you know 100% theres no air in the system, it will be the themostat in your truck.

  4. #4

    Default

    Quote Originally Posted by T-bone View Post
    yes you have air in the system and it is sitting in your heater core and you need to get the air out.

    is your overflow reading max at cold?

    when you start the truck does the level drop when running?


    you could try driving the car a short distance and then carefully releasing the pressure to burp the system of extra air. Given it is a closed system, you need to get the air out some how. Drive, burp, and add more coolant if you need to and it should work itself out.

    Yes my overflow is at max, and no the level does not drop at all.
    I would agree with you because the feed line (inlet line) to the core gets hot like there is fluid in it but the return line is cold/warm when I turn the heater on.
    ive tried doing what you said and what Bacarian said to bleed out the air in the core but I'm not having any luck.
    Any other suggestions as to how to get the air out?
    2003 Chevy 1500 5.3l VORTEC

  5. #5

    Default

    it can be the thermostat, too! when it`s failure the thermostat can not open and your it works only the wrong watercirculation you can putt it out and do it in a hot water. than you will see, if its ok!

  6. #6

    Default

    Quote Originally Posted by Bavarian View Post
    it can be the thermostat, too! when it`s failure the thermostat can not open and your it works only the wrong watercirculation you can putt it out and do it in a hot water. than you will see, if its ok!
    Agreed.

    To the OP. tell us how hot your temp gauge reads when you are at operating temperature? if it spikes (looks normal then gets really high then dives again...) you have air. If reads lower than normal or higher than normal I think it could be the T-stat is not working.

    In this case you will have to replace it which is a PITA (just did this). The T-stat is installed on your water pump. to access you need to take off the air intake, fan cowl and sadly your lower radiator hose which means you are doing another coolant change. two 10mm bolts hold it on & there is an O-ring gasket that will need to be replaced.

    The Beach of it is the fan clutch assembly that is threaded onto the water pump pulley. this will need to come off to get access to the pump/T-stat.

    Note there are two different kinds of T-stats as I understand one where it is a single unit with its own housing and a unit where the T-stat comes out of the housing. get both use the one that resembles the one you need and return the other or just take it off and go to the parts store after.

    Still hoping its air for you sake report back on the temperature regulation while its fully hot. I do not know the temperature the OEM unit opens but if you can find that out when you watch the engine warm up when you reach that temperature you will see a nice dip in temp when it opens. If it does that we are back to air in the system.

    Did you flush the system or just empty and refill? Where did you get the correct procedure?
    1995 Saturn Sw1 196K and counting
    2001 Suburban LS 150K and counting
    2004 MR2 Spyder 62K and counting
    2007 mini cooper S 60K and counting

  7. #7

    Default

    When the input hose is hot and the output is cold (no heat), loosen the output hose to purge the air, if there is any, out. Be careful not to burn your self.

    A slight chance that the heater core is plugged up. A 9 year old coolant system, parts corrode and junk could be stuck in the core. As it gets hot the junk expands. It's an easy flush, just remove the heater hoses and with very low pressure from a garden hose and run clear water through the core. Flush the it in the opposite direction of the flow from the water pump.

    The thermostat may be sticking close, the engine gets very hot and then the thermo pops open but it doesn't close again. However, an open thermostat or cold engine will kick on the check engine light. The code will be "low coolant/engine temp". But this is probably not your problem.

Similar Threads

  1. PCM B Fuse blowing on '91 sub, 350 TBI -- PLEASE HELP
    By rdnkdrummer in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 1
    Last Post: 12-04-2012, 10:49 PM
  2. AC blowing hot air
    By aircooled81 in forum General Chevy & GM Tech Questions
    Replies: 2
    Last Post: 09-26-2012, 09:56 AM
  3. blowing fuse
    By bowershed in forum General Chevy & GM Tech Questions
    Replies: 1
    Last Post: 03-30-2010, 07:13 AM
  4. headlights blowing out
    By DaleP in forum General Chevy & GM Tech Questions
    Replies: 0
    Last Post: 03-10-2010, 09:40 AM
  5. Keep blowing fuses
    By sayala in forum Audio, Video & Gadget Tech
    Replies: 1
    Last Post: 10-03-2007, 05:41 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •