GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 4 of 4
  1. #1

    Default 2005 Chevy Tahoe rear air issue.

    Hello...New to the forum. I was working on my 2005 Tahoe . The issue is a code that comes up from the rear air (B0434). The problem is the rear air will not switch from hot to cold. Both lines feeding the rear have hot and cold pumping through them. The door that the hot and cold actuator is connected to moves with no obstruction by hand. The steps I have taken thus far are fixing the suggested part that the Bulletin listed as the cause of the code. The air temp actuator and the auxiliary mode actuator both replaced. All parts are the most current to flash upgrades. I cant get the air to blend from cold to warm. All systems reflashed and then the code fires back. When the diagnostic is hooked in the parameters for all actuators are within range and the system can be used with no trouble. As soon as We release the truck after the flash the code comes back and the sytem goes to full cold in the rear air only. Front air has no issues at all. Really lost at this point...first time I have not had a bulletin repair suggestion fix the issue...i have not had really any issues with my Tahoe but this came out of the blue..We just got out of the summer months and needed warm air in the back..this is when i noticed the problem. i have not performed any recent work as far as electrical or battery. Any help would be great. Thank you!! Matt. Part for aux module was 15832319.

  2. #2

    Default

    The Tech II must be providing something that is missing under the current conditions.

    It appears, that your current "normal" position for the temp/blend door is full cold, that may be because either battery, or ground, is missing. When the Tech II is plugged in, the missing condition (battery, or ground) is feeding through the tech II.

    Edit: have you checked all of the fuses?
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

  3. #3

    Default

    Quote Originally Posted by RayVoy View Post
    The Tech II must be providing something that is missing under the current conditions.

    It appears, that your current "normal" position for the temp/blend door is full cold, that may be because either battery, or ground, is missing. When the Tech II is plugged in, the missing condition (battery, or ground) is feeding through the tech II.

    Edit: have you checked all of the fuses?
    I will check fuses tomorrow. Can these have a ground that goes bad? I have had to search force volt source problems and ground issues before in cars i have owned in the past and dread it. I see what you mean by the Tech II Working and thetruck cant function off the Tech...I have just began into this so will do some further searching. I wonder if the modual in the rear control behind the center councel could be bad. I am begining to think I may have replaced the wrong modul??? The bulliten did print and read Modul assembley- auxiliary heater & ac control. I took that as the one in the rear housing by the third row seat. Either way I will continue the hunt for more information and possible causes. Thanks a bunch for responding.

  4. #4

    Default

    Yes, the grounds can be a problem. I can't speak of yours, but the '05 Envoy, I had, was notorious for bad grounds, mostly loose and corroded.
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

Similar Threads

  1. 2005 Tahoe - "Rear Access Open"
    By car99r in forum Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)
    Replies: 12
    Last Post: 03-17-2014, 11:58 AM
  2. 1996 Chevy Tahoe Ac issue. Blowing Hot
    By MY97CHEVY in forum General Chevy & GM Tech Questions
    Replies: 2
    Last Post: 08-05-2012, 10:49 PM
  3. 2005 gmc hd starting issue
    By 2toejoe in forum General Chevy & GM Tech Questions
    Replies: 3
    Last Post: 04-23-2012, 04:21 PM
  4. 2005 Tahoe Z71 Rear Door Lock Problems
    By UTFan69 in forum General Chevy & GM Tech Questions
    Replies: 0
    Last Post: 03-13-2010, 12:44 PM
  5. 2007 Tahoe Rear Seat Latch Issue
    By ace2878 in forum General Chevy & GM Tech Questions
    Replies: 1
    Last Post: 01-12-2010, 09:47 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •