GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 9 of 9
  1. #1

    Default ABS and traction control lights on

    Hello,
    I have a 2007 GMC sierra SLE new style body 5.3L z71 crew cab. The ABS and traction control lights came on about 6 months ago, and at that time and I was able to determine that the left front wheel bearing was faulty. I decided to change both front wheel bearings, and the ABS and traction control issue was fixed. The traction control light and ABS lights have come back on. I have bad drag when I turn either left or right now to the point where the back tires spin. I had the vehicle 4 wheel drive in auto mode. I read that the vehicle is in auto mode until the vehicle reaches a certain speed. I doubt the issue is the wheel bearings again cause there is no noise like before. My buddy told me to turn the vehicle from auto mode to just 2 wheel drive so when I did the drag disappeared and the vehicle turns with ease now. My problem is that when I trun it back to auto or 4x4 mode the drag comes back when I turn left or right. Any ideas as to what the problem might be? I do have some mechanical background, I am guessing either the front drive drain and or the electric shift motor in the front drive train. I would like to know if I could change it myself if its just the electric motor.
    thank you in advance for the information.

  2. #2

    Default

    Welcome to GMTC scooby. Somebody on the site should be able to help you with your problem.
    1994 GMC Yukon, 2 door, Victory Red
    Garage Link: http://www.gmtruckclub.com/forum/sho...1994-GMC-Yukon

  3. #3

    Default

    Welcome to the club, it's good to have you aboard.


    2002 Chevrolet Silverado Extended Cab SportSide: See Mods in My Garage

  4. #4

    Default

    Welcome to the G M T C ! If you don't get some information before long, try posting in one of the "Tech." forums. We have a lot of great folks that are glad to share. Good luck!


    2010 Z/71 Colorado C/C
    Black 4X4 w/5.3L V8
    ===============
    2007 Winnebago Adventurer
    w/8.1L Chevy & Allison 6spd.
    Canyon Lake, Texas

  5. #5

    Default

    Welcome!

  6. #6

    Default

    When in 4WD, the rear driveshaft and the front driveshaft split the available power 50/50; when in AUTO 4, the transfer case should send most of the torque rearward and a little (5%) forward. When the sensors detect rear wheel slippage, the t-case control module tells the t-case encoder motor to lock up the clutches so the torque is split 50/50.

    The binding that you feel when in 4WD is normal, that is why the manual tells you to only use 4WD when the road surface is loose, or slippery. You should be able to run on hard dry surfaces when in the AUTO 4 position, there should be sufficient slippage in the clutches to let the front wheels turn without binding.

    You might be having problems with the encoder motor, which is an easy change; however, I would change the t-case fluid first, the clutches may just need new lub.
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

  7. #7

    Default

    Hello RayVoy,
    thanks for the reply!! I'm up in Canada and we got snow, lots of it, the ABS/traction control has shut its self off and the ABS and traction control lights remain on, even on slippery surfaces its hard for the wheels to turn without binding. I will try changing the t-case fluid first like you suggested but I find I am never that lucky...Its probably the encoder motor, will let you know.

    Thanks again

  8. #8

    Default

    I went back and reread your 1st post; your right, you may not be that lucky.

    I missed the part about the lights coming back on.

    There is a possibility that the 2 problems are connected, or, perhaps you have 2 problems.

    There may be an additional sensor problem that is disabling the ABS and TC.

    Changing the fluid (if it's been in there for awhile) may help the binding, but the lights will probably still be on.

    I'm in NB (no snow), where are you?
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

  9. #9

    Default

    RayVoy,
    first...I am from Ontario Canada, and it just keeps snowing. I gotter fixed today. You were correct. I took a second look at the lights that came on the dash board and noted that the tire pressure monitor for the right front passenger side was giving me a bogus reading way below the normal but on manual check it was at acceptable pressure and the light was giving me a warning. I read that the pressure senors in the valve stem rely on a few sensors. I checked all the sensors and found that the right rear passenger side sensor was faulty. I changed the transaxle oil, transmission oil and the lights remained on. I changed the right rear sensor and bam!! lights were gone and it fixed the tire pressure sensor too. I got my ABS, Traction control, and tire pressure readings all back. The encoder motor is working thank god and its disengaging appropriately. Thanks for pointing me into the right direction....I was just hoping it wasn't the sensor in the encoder motor itself as the right rear sensor was alot easier to change.

    Scooby

Similar Threads

  1. Help!!! Service Traction Control lights and ABS lights will not go off after lift....
    By Nath in forum Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)
    Replies: 1
    Last Post: 10-03-2012, 10:35 AM
  2. HELP! Traction Control
    By LB'07-Z in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 6
    Last Post: 08-24-2011, 12:56 PM
  3. Traction control/ABS
    By alabamaxrebel in forum Lifted & Offroad Suspension
    Replies: 3
    Last Post: 03-23-2011, 02:58 PM
  4. Traction control
    By Malek in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 0
    Last Post: 01-12-2009, 04:21 PM
  5. Traction Control and ABS lights
    By rssjib in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 1
    Last Post: 12-17-2008, 06:41 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •