GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 7 of 7

Thread: 4x4 problems

  1. #1

    Default 4x4 problems

    My 4wd is not engaging, and making a disturbing sound. Before i tear into it, i would like to discuss. I have trolled the forums and have not seen my exact issue. Sorry if this is obvious but im not coming up with it.

    My truck stopped going into 4High. Push the button, flash flash flash and nothing. no sound from module or actuator. Push 4low, a nice solid chunk and we are in business. Solid light on 4 low. Push 4low again, the lights would change to indicate solid 4high, blinking 4low, but stay in 4low. Push 4high, truck would return to 2wd.

    To start simple repairs, i disconnected the battery for an hour.

    Now things get interesting. When i push 4high or 4low, there is a LOUD clank, and no engagement at all. Tried a few times. The module clicks and the Transfer Case case goes CLANK really loud and nothing. I drove the truck and tried again, and the CLANK got louder, almost violent. you can feel it through the whole truck. Even my kid was like "What the hell was THAT!?". so i stopped pushing buttons.

    I figure i can replace the Switch, Module and Actuator, but before i start this project, I would enjoy some feedback.

    Thanks all, and Happy Holidays
    James
    Oakland
    First Time Poster
    Last edited by Pikey; 12-09-2012 at 01:02 AM. Reason: FSC forum link in post

  2. #2

    Default

    Quote Originally Posted by JamesE View Post
    I figure i can replace the Switch, Module and Actuator,
    Welcome to the site James, I don't think it is any of the above. I have no experience with the t-case (been lucky), but I feel I am knowledgeable about the theory of operation.

    I think you have a bad encoder motor.

    From what I have read, very easy to change. If it was me, I would do a search on encoder motor to ensure my guess is correct and, to ensure you feel comfortable changing it.

    Regardless of the eventual outcome, occasionally changing the t-case fluid is a good idea.
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

  3. #3
    Jr. Mechanic BillM's Avatar
    Join Date
    Sep 2010
    Location
    Fair Oaks, CA
    Posts
    112

    Default

    Welcome to the Club, James.
    As Ray mentioned, you may be able to run a test on the encoder motor? Disconnect the motor from the transfer case, and open up the gears. They could be damaged. An aquaintance had a similar problem with his Avalanch, and there was some plastic gear damage and pieces jaming the encoder? My encoder does not have any plastic in it??
    A test may be possible by having the encoder motor hang by the electrical cable and running through the buttons - 4 Low; 4 High; 2 WD; and Auto if you have it. The encoder motor should move through the positions as the buttons change.
    I am sorry, but I did not get the make model and year.
    Bill M. Blown 2003 Tahoe Z71

  4. #4

    Default

    Thanks Guys,
    I hit the pick and pull today (saw a 99 yukon new to the yard) and claimed the dash switch, under-dash encoder, front actuator, and the rear motorized transfer mechanizm (that would be the encoder motor, right?).
    Ill start by changing the transfer case oil, because i'm pretty sure i hear noises from each part of the system. Maybe those plastic gears are shredded inside the encoder motor, so i'll go there second. Not hard to remove, but requires a few tricks. Gets a little tight against the drive shaft. Thanks for the guidance.
    Happy New Year-!
    james

    - - - Updated - - -

    PS.
    1997 GMC Suburban SLT K1500

  5. #5

    Default

    Hi All-
    okay, the pick and pull parts didn't match.
    So- replaced NEW Dash switch, NEW front Actuator, New Encoder Motor (Transfer case motor).
    Truck goes into 4lo again, but no 4hi.
    Getting the blues. any further advice?

    thanks
    james
    97 suburban K1500
    James; Oakland CA
    1997 GMC Suburban K1500
    1990 BMW 325is
    2002 Saab 9-3 turbo

  6. #6

    Default

    James, the only thing left is the TCCM (Transfer Case Control Module), it's the brains of the whole system. It would be nice to get a loaner from a friend, with a matching truck, to try
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

  7. #7

    Default

    Ok, swapped out the brain from under the drivers dash.
    Nutty! same exact symptoms. No 4hi. 4low is perfect, a total grunt monster.
    I am baffled.
    James; Oakland CA
    1997 GMC Suburban K1500
    1990 BMW 325is
    2002 Saab 9-3 turbo

Similar Threads

  1. 96 Suburban Turn Signal Inop, ABS Problems & Convertor Problems
    By rowekmr in forum General Chevy & GM Tech Questions
    Replies: 5
    Last Post: 05-14-2012, 04:43 PM
  2. 4x4 problems
    By SPCMarty in forum Chevy C/K Truck Forum
    Replies: 3
    Last Post: 08-01-2010, 07:35 AM
  3. AC problems
    By AnsteyZ71 in forum General Chevy & GM Tech Questions
    Replies: 2
    Last Post: 06-24-2010, 10:23 PM
  4. Chevy Silverado Heater problems blower problems
    By bidutch in forum GM Powertrain
    Replies: 3
    Last Post: 12-13-2007, 05:59 PM
  5. Got a few problems
    By 95chevyguy in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 4
    Last Post: 04-16-2007, 12:03 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •