GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 7 123 ... Last Post byLast Post by
Results 1 to 10 of 66
  1. #1

    Default Mysterious Coolant Leak

    Hopefully someone can help me out. I have a 2000 Silverado with the 5.3L engine. Recently, I have been losing coolant at a slow rate. I have had the cooling system pressure tested by a dealer and an independent mechanic and both say that there is not a pressure leak in the system. I have checked the oil and I do not see any indication of antifreeze in the oil, so I do not suspect a head gasket problem.

    Also, there is no visible signs of coolant leaking from the system (I see no coolant on the ground under the car and the engine compartment does not smell of coolant). So, if the pressure is good and the head gasket appears not to be the problem, where is the coolant going? I have changed the radiator cap on the surge tank, but this did not appear to help. Has anyone else seen a problem like this? I am going crazy (not to mention spending a lot of money doing pressure tests!) with this problem.

    Anything will heip. Thanks!
    Last edited by ChevyFan; 02-08-2008 at 10:39 AM.

  2. #2

    Default

    First welcome aboard.

    If you don’t have a pressure leak in the system I really don’t think you have anything to worry about.

    But if you start loosing more coolant, more quickly I would have the test done again and this time with a die that will show up under a light. It just makes it easier to see where the leak is coming from.

    Technology is great, when it Works,
    And one Big Pain in the Ass When it Doesn’t.
    Detroit Iron Rules, All the Rest are Just Toys.
    94 GMC Burban, 5.7L (350), 4X4, Auto
    86 GMC Burban, 350, 2 WD, Auto
    79 GMC pickup plow truck, 400, Full time 4X4, Auto
    86 Pontiac Fiero SE, 2.8L, Auto, only mid engine American car
    See a Pattern yet?

    15 year GM assembly line worker.

  3. #3

    Default Thanks

    84fiero123, first thanks for the warm welcome. Second, thanks for the truck advice. Right now, the temp does not budge from the normal temp, so it appears it is not a big deal. It is just inconvient to fill the surge tank with 1Q of antifreeze every 1.5 months or so. Hopefully it does not get worse.

  4. #4

    Default

    Check the surge tank and connecting hose, this is the only part of the cooling system that isnt pressurized and wont show a leak when you do pressurize the system.
    Almost all surge tanks are plastic and they break down from the heat after a while.

  5. #5
    Jr. Mechanic
    Join Date
    Jan 2008
    Location
    Ashland Missouri
    Posts
    85

    Default

    I have a mystery machine like that also.My old 97 Z-71 is losing antifreeze but i can smell it when it is setting still at an idle but there is never any signs of a leak. I can park it on the concrete or in the garage and let it set overnight and everthing is dry the next morning. I probably add a quart every couple of months.I have a pressure tester, guess i should put it to use,huh? Just might do that today.
    Terry

    2004 Tahoe (wifes)
    2004 Silverado 2500HD Duramax
    1997 Chevy Z-71
    1953 Golden Jubilee

  6. #6

    Default

    Duramax04-
    Let me know what you determine from your pressure test. If your problem is anything like mine, the pressure test will come out fine, and the mystery will continue.

  7. #7
    Jr. Mechanic
    Join Date
    Jan 2008
    Location
    Ashland Missouri
    Posts
    85

    Unhappy

    Quote Originally Posted by Cal_truck22 View Post
    Duramax04-
    Let me know what you determine from your pressure test. If your problem is anything like mine, the pressure test will come out fine, and the mystery will continue.

    Cal, your exactly right. Pressure test was good and cap checked out okay. Back to scratching my head.

  8. #8
    Former Member
    Join Date
    Oct 2007
    Location
    Huntsville, Alabama
    Posts
    372

    Default

    I had a similar problem on my old silverado. The source of my problem was at the back of the intake. When the engine was warm it would leak, but would burn off before anything touched the ground. When it was cool, nothing leaked at all. It was a pesky problem and I sold the truck (unfortunately) before I was able to fix it.

  9. #9

    Default

    JayMack75-
    How did you determine that the intake gaskets were the problem? After I drive the truck for a while, I lift the hood and try to smell any coolant in the engine compartment. However, I smell nothing. If it is only leaking when driving, would I be able to smell coolant in the engine compartment? The problem in my truck is starting to get a little worse, so I am getting more concerned about the problem. Thanks.

  10. #10

    Default

    Cal,
    Have you located your mystery leak?
    I'm having the same problem on my 2001 c1500. No visiable leak but I need to add a quart of coolent about once a month.

Page 1 of 7 123 ... Last Post byLast Post by

Similar Threads

  1. Coolant leak...
    By Jcloud in forum General Chevy & GM Tech Questions
    Replies: 10
    Last: 07-12-2010, 07:06 PM
  2. coolant leak ?
    By dsquared in forum General Chevy & GM Tech Questions
    Replies: 8
    Last: 06-28-2010, 07:52 PM
  3. mysterious Coolant Leak/Sludge in Oil
    By jukebox in forum General Chevy & GM Tech Questions
    Replies: 0
    Last: 03-07-2010, 10:11 AM
  4. Mysterious Oil Leak
    By Selbona in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 2
    Last: 11-17-2009, 09:35 PM
  5. Coolant leak Q
    By TJbear in forum GM Powertrain
    Replies: 8
    Last: 10-29-2009, 12:13 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •