GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 5 of 5
  1. #1

    Default Temperature Gauge

    Friday morning the hydraulic pump shorted on my snow plow and wreaked havoc on my battery. The post for the positive terminal broke off and all the lead surrounding it actually melted and dripped everywhere. Got a new battery and everything is working fine.

    The only thing not working is the temp gauge on the dash. When I turn over the engine to start it spikes all the way up, but immediately drops to zero and never moves after that, regardless of temperature.

    i replaced the coolant temp. sensor. if i disconnect the tcs while truck is running the check engine light comes on so there is a signal going to the sensor... Somoeone mentioned a "coolant temperature SWITCH" - but i can't find any info about that, or if it really exists. I"d rather have a temperature gauge so I want to fix this. Short of replacing the instrument cluster, I'm out of ideas. Any advice?

  2. #2

    Default

    run a jumper wire between the pins on the coolent temp sender. That will make it peg out and let u know that the dash is working also.
    HI MY NAME IS. HI MY NAME IS. HI MY NAME IS.
    BJ

    1993 GMC K2500 Suburban 5.7L Jegs 8.0mm wires, Jegs Red Hot Coil, Jegs Cap & Rotor, Accel U-Grove Plugs, Cold Air Intake, Holly Headers, Manderal Bend Y-Pipe, Super 40 Muffler, M/T Classic II sitting on BFG A/T (MINE)

    [COLOR="Magenta"]1994 Chevy S10 Blazer 4X4 4.3L CPI. Delta Flow 50 Muffler.(Wifes) DIED.. Cab mounts rotted out.. Parting out need anything let me know!!!!

  3. #3
    Legend unplugged's Avatar
    Join Date
    Sep 2006
    Location
    High Deserts of SoCal
    Posts
    2,554

    Default

    Coolant temperature sensor is located in the intake manifold near the tstat housing. The coolant temperature switch is located on the drivers side cylinder head near the front between the exhaust ports.

    Check the block to chassis ground cables. Should be between the block and frame. You can use a jumper cable to test the connection/gauge.
    Last edited by unplugged; 02-06-2008 at 12:57 AM. Reason: more info
    There is no way to happiness....happiness is the way.:yipi:
    http://kx6ijq.blu.livefilestore.com/y1pcOFVNH4ix1hjyGUVyXK5LRfef7qSeWzlZDorpQhIEfkZ2ZA  _vXMYypuKMJFw671uF2ZPhjez_j-atRmcjM2zQKpQi1JSsB75/burb1.JPG
    High Desert SoCal
    93 K1500 burb (personal) 350 AT 3" Lift 250K+
    02 Honda Civic LX
    Looking for a 1990's Miata for an engine swap

  4. #4

    Default Electricals on the fritzzzz

    Yikes, this problem has gotten worse. Now the headlights are funky and the instrument cluster is more messed up than ever. If i turn on the lights I'm usually ok. If i turn on the heater it shorts out and i lose my gauges. Same story with the 4wd. I drop the T-Case into 4hi and everything dims and it wont engage.

    This problem is intermittent, however and from time to time the 4x4 will engage. The Speedometer/Odometer come and go but the fuel gauge, & temp gauge never work.

    I'm lost. Someone mentioned an alternator problem, and I'm not sure what you mean by the chassis ground cable.. Can you explain what that means?

  5. #5

    Default

    The Battery's negative terminal is connected to the Frame and engine block (with a lead going to the starter).
    There should be smaller ground wires running between the body and the frame, and the body and the engine block.
    Use a jumper cable to check the connection to each of these points to determine if the ground wires have been compromised.
    Check the Battery to engine block first.
    Then battery to frame.
    Then engine block to body.
    Finally frame to body.
    The engine block to body and frame to body should be performed last if you have bad grounds at the other points and you hook a good ground through the body when you turn on the juice you could possibly melt the ground point on the body because of the thin sheet metal.

Similar Threads

  1. Transmission Temperature
    By cigar_stub in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 20
    Last Post: 06-26-2013, 08:37 AM
  2. Transmission Temperature
    By at4rxj in forum GM Powertrain
    Replies: 6
    Last Post: 06-15-2010, 01:18 PM
  3. Temperature
    By Stealth in forum The Coffee Shop ~ Chit Chat
    Replies: 7
    Last Post: 04-07-2010, 10:15 AM
  4. Temperature Gauge Help [Expired Topic]
    By jerseyfred in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 19
    Last Post: 12-06-2006, 12:14 AM
  5. Coolant temperature on a 94 454 [Expired Topic]
    By AndyD in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 6
    Last Post: 08-05-2006, 10:38 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •