GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 8 of 8
  1. #1

    Default 05 silverado brake issues please help

    I have an 05 silverado crew cab with disc brakes on the front and drums on back, went to replace pads on front because of squeeking (this is second time i replaced pads) when I pulled them off the pads looked like they were riding about a quarter inch or so above the rotor, like the rotor was to small or the pads were to big, cheked with the chevy place they said those were the right pads. and I know the rotors haven't been replaced because I bought the truck new and have done all the brake work myself, has anyone ever seen this problem.

    This very hard to explain so maybe this pic will help a little.
    Click image for larger version. 

Name:	untitled.jpg 
Views:	63 
Size:	69.8 KB 
ID:	46856
    Last edited by burbach1; 12-14-2012 at 12:07 AM. Reason: added picture

  2. #2

    Default

    OK I am new to this and maybe I did it wrong, or this problem is so unique no one has ever seen it I've got plenty of views and 0 replies, could some one please reply and let me know which it is. I really do not want to have to take this to the dealer and pay hundreds of dollars if it is a simple fix.

  3. #3
    Jr. Engineer Jamm3r's Avatar
    Join Date
    Dec 2012
    Location
    Minneapolis area
    Posts
    240

    Default

    Never seen pad wear like that before. Are they that way on both of the front wheels?
    Minneapolis area - 1997 K2500 regular cab long bed + 8.5' Western Unimount plow + modified transmission + 2nd battery + modified camper charge circuit + 1971 Cayo camper -and- 2004 4x4 Suburban 2500 8.1 + Maxbrake controller + 2nd battery + modified trailer charge circuit + Reese receiver, pulls 30' Airstream trailer

  4. #4

    Default

    are you sure that the pad is riding off of the rotor? When they are on the truck are they sticking out past the rotor? I have seen wear like that. But, everytime it was because the pads were not held flat on the rotor during install and were slightly cocked or they were not sliding freely on the mounting clips. (I have had to file the ears on some autozone pads to get them to move freely). I have also seen a rotor casting issue cause odd wear like this. Some hard spots in the casting don't wear like the rest of the rotor leaving high spots. (I have seen this happen in the middle of a pad.) I always hold the rotor in place with a lug nut when I install new pads. It keeps the rotor in the proper location. Then I install the pads and caliper. I press the brake pedal to be sure that the caliper is squeezing the pads flat against the rotor. Then I remove the lug nut from the wheel stud, remount the tire, and move on to the other side. This ensures that the pads are properly seated against the rotor. It does look like you have some "breakout" on the outer lip. Is your rotor rusted severely on the out edge?

    1995 Silverado 4x4
    6" BDS Suspension Lift-3" Body Lift-Add A Leaf in rear -Trailmaster SSV Shocks-Duel Steering Stabilizer Kit -AirAid Cold air intake-
    4.56 Gears with Detroit Auburn Locker-Pro-Comp Traction Bars with duel shocks-Aluminum Skid Plate Kit-38.5" x 16.5" Mickey Thompson Baja Claws-Constant Dropping fuel gauge

    2005 Yukon XL Jet Power Programmer, Bilstein Shocks, Bilstein rear springs, Helwig Anti-sway bars, EGR Window Visors, EGR Hood Shield, Denali Headlights, Headlight harness upgrade, GE NightHawk Bulbs, White Night Rear lighting system, Russell Braided SS brake lines, PowerStop Brake pads, PowerStop cross drilled and Slotted Rotors, http://www.gmtruckclub.com/forum/sho...5-GMC-Yukon-XL
    2002 Silverado ext cab 2wd (Sold)
    2003 Yukon XL (Totaled)

  5. #5

    Default

    they are that way on both front wheels inside and out

  6. #6

    Default

    do they actually hang over the rotor? I don't think that the incorrect sized pad would fit in the slots in the caliper mounting bracket. If they were to big then the caliper would not fit on either. I am sorry to say that I think that it is either a rotor issue (no likely to happen on both sides at the same time) or a install issue, either cocked or not sliding properly. Either way you look at it, you are probably going to replace the rotors and pads. (hope you bought lifetime warranty pads). If I were doing it I would also purchase a good hardware kit that includes, new mounting clips, new rubber slide seals, new slides. They can be hard to find.(the complete kit, not the cheap kit with just clips) I think that NAPA has them, but autozone and advance does not.

  7. #7

    Default

    yea they are riding off of the rotor on the truck, you can look from the top of the rotor and see the pads sitting about a quarter inch above the rotor, the top edge of the rotor is shiney were the pads have been riding, also noticed bottom of rotor towards the hub has a what seems to be wider area where you can tell the pads have not been riding, I think the break out is just where they have been thrown in and out of the box from showing everyone I know to try and find an answer

  8. #8
    Jr. Engineer
    Join Date
    Aug 2010
    Location
    eas' bum fuk, maine
    Posts
    207

    Default

    Are the rotors the right size for ur truck? I remember once working on an extended trailblazer that someone put regular trail blazer rotors on and that causes the rotors to be smaller then the pads because they were a smaller diameter

Similar Threads

  1. Brake issues (does my truck have abs?) 04' Silverado
    By Bowtied in forum General Chevy & GM Tech Questions
    Replies: 4
    Last: 11-29-2012, 02:07 PM
  2. Brake issues
    By khurrle in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 9
    Last: 07-11-2012, 08:22 PM
  3. Brake Issues
    By chvyfun in forum General Chevy & GM Tech Questions
    Replies: 4
    Last: 04-25-2012, 06:57 PM
  4. 1997 Silverado Brake light issues
    By jtrout88 in forum Chevy C/K Truck Forum
    Replies: 2
    Last: 10-02-2011, 02:48 PM
  5. GMT 900 Brake issues?
    By lgrppup in forum Lifted & Offroad Suspension
    Replies: 1
    Last: 08-01-2009, 09:51 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •