GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 3 of 3
  1. #1
    Jr. Apprentice
    Join Date
    Apr 2012
    Location
    Bancroft IA
    Posts
    17

    Default 92 350 issues!!!!

    I have a 92 K1500 it has the 350. recently did a full tune up including coil, as of today it has no spark checked for spark at the plug and the coil. Also for some reason not spraying any fuel at the throttle body, fuel pump comes on when you turn the key and remains on while cycling the engine. I checked for fuel at the line to the throttle body there is fuel there. As for the spark issue was thinking ignition module. Any help is greatly appreciated.

  2. #2

    Default

    I'm thinking it's the ignition module as well. If it doesn't give a signal, the injectors won't spray.
    ...
    ....

  3. #3
    Jr. Apprentice
    Join Date
    Apr 2012
    Location
    Bancroft IA
    Posts
    17

    Default

    Thank you Chris the control module was the issue. Replaced with a new truck runs great.

Similar Threads

  1. help! 92 issues
    By cooter71 in forum Chevy C/K Truck Forum
    Replies: 1
    Last: 12-16-2012, 01:32 PM
  2. vss issues 92 k15
    By Snoopius in forum Chevy C/K Truck Forum
    Replies: 19
    Last: 10-08-2012, 12:38 PM
  3. ABS Issues
    By Magna86 in forum Lifted & Offroad Suspension
    Replies: 1
    Last: 02-25-2011, 02:58 PM
  4. same issues? ('97 vs '98)
    By redbone in forum General Chevy & GM Tech Questions
    Replies: 0
    Last: 04-07-2010, 05:33 PM
  5. ABS issues
    By hutch_pt in forum Lifted & Offroad Suspension
    Replies: 5
    Last: 05-10-2009, 03:36 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •