GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 7 of 7

Hybrid View

  1. #1

    Default I think i blew a fuse need help plzz!!

    Help me, I did somthing Stupid!!
    I bought some small driving lights yesterday. My thoughtwas to hook them up to the reverse lights for more light. I live in the countryand i have really dark windows so more light is needed. Worked great with onebut when i added the second one it blew something. I spliced into the reverselights them self’s. Now i have no reverse lights or cab lights. I have checkeda bunch of fuses can't find any blown. Weird thing tho, one light of the domewill work at a time??? Please help this is my DD and need it for work.
    Thanks

    Chevy 1500
    2006 crew cab Z71


  2. #2

    Default

    You should have used a relay to control the aux lights. You may have damaged a larger fuse in the under hood box so check there. If you really have found no damaged fuses and relays then I'm not sure what is damaged.

    Here is a diagram for when you redo the wires.
    Click image for larger version. 

Name:	fiamm_relay_diagram2.JPG 
Views:	85 
Size:	19.2 KB 
ID:	46980

    1996 Chevy Tahoe LT 5.7L V8 4X4 205,000+ miles. Built proudly at Janesville Assembly in Janesville, Wisconsin
    Basic mods: Lights all over, bunch of electrical work, and a couple cooling mods.

    Check out my other mods in My Garage: http://www.gmtruckclub.com/forum/sho...t-Tahoe-4-Door

  3. #3

    Default

    Thank you for that diagram. Any idea where i would buy a relay like that?? Would i run the power from the battery? If so should i put the realy at the battery or run a power wire from the battery back to relay by the lights?? Thanks again for helping this shade tree tech, Hopefuly someone will post an anwser for me. I would hate to put it in the shop for something like this.

  4. #4
    Master Mechanic zigger215's Avatar
    Join Date
    Sep 2011
    Location
    Fairbanks, Alaska
    Posts
    551

    Default

    Quote Originally Posted by Conlan Rose View Post
    You should have used a relay to control the aux lights. You may have damaged a larger fuse in the under hood box so check there. If you really have found no damaged fuses and relays then I'm not sure what is damaged.

    Here is a diagram for when you redo the wires.
    <img src="http://www.gmtruckclub.com/forum/attachment.php?attachmentid=46980"/>
    Relays make the world go round'. Lol

Similar Threads

  1. 95 S10 4.6 TBI, ECM blew
    By Alkali25 in forum Chevy S10 Forum (GMC Sonoma)
    Replies: 8
    Last Post: 12-24-2013, 08:34 PM
  2. Replies: 13
    Last Post: 12-18-2012, 04:29 PM
  3. plzz help. tbi 350 ??????????
    By 95chevy in forum Chevy C/K Truck Forum
    Replies: 1
    Last Post: 12-04-2011, 12:14 AM
  4. What fuse is my third brake light fuse?
    By b_burdine in forum General Chevy & GM Tech Questions
    Replies: 1
    Last Post: 11-04-2009, 07:18 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •