GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 2 12 LastLast
Results 1 to 10 of 19
  1. #1

    Default Four Wheel Drive Acting Funky

    Hi guys,

    I have a 2000 silverado Z71 4WD. I was driving up to the local ski resort the other day and kicked it in four wheel high. The roads were snow covered. I drove a little ways and noticed the 'Service 4WD' light came on. Afterward, it would not kick out of 4 High until I shut off and restarted the engine. I noticed this problem at the Outer Banks this summer using 4WD there as well, and took it for diagnosis, but no errors were found, even with that light on. Any ideas? It kicks in and 4WD works, it just doesnt want to come out after that light comes on. I had it happen before where it would not come out unless I disconnected the negative battery terminal as well. Also, it sometimes seems like it physically comes out, but the display on the push buttons doesnt show it, it still shows as being in 4WD. Any ideas would be great.

    -Rob

  2. #2

    Default

    Did you put it into/out of 4x4 while in drive? Sometimes they'll hang up it the truck is in gear. I usually shift into neutral to do that. Actually, my truck will only shift into 4lo if it is in neutral, it won't do it if it's in park.
    It could be the actuator or maybe the transfer case needs oil or an oil change.
    You're driving is WAY more offensive than my swearing, assjack!!!


  3. #3

    Default

    I know that encoder motors caused issues with those. It's push button correct?
    David
    2004 Silverado 2500 Crew Cab 4x4, AMSOIL EA air filter, Granatelli MAF sensor, Throttle body spacer, Magnaflow exhaust (true dual to 2 in 1 out muffler), 6" ProComp lift (add a leaf and 5" superlift rear block), Bilstein shocks, 35's (Cooper Disoverer ST) and 4.10 gears, Rhino Liner, EGRUSA fender Flares and widow visors, extended stainless steel brake lines, firestone airbags w/onboard air compressor, Pioneer Avic X940BT navigation, Accel backup camera.
    http://www.gmtruckclub.com/forum/sho...Silverado-2500
    1960 Land Rover Series II 88
    2001 Pontiac Sunfire
    2013 Toyota Avalon Limited (Wife's Car)
    NRA Life Member

  4. #4

    Default

    Quote Originally Posted by dsfloyd View Post
    I know that encoder motors caused issues with those.
    Yeah, they do. Sometimes, if your real lucky, changing the t-case fluid will give new life to the encoder motor (it needs to move clutch plates).
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

  5. #5

    Default

    Quote Originally Posted by RayVoy View Post
    Yeah, they do. Sometimes, if your real lucky, changing the t-case fluid will give new life to the encoder motor (it needs to move clutch plates).
    Yes, its push button. Its definitely working, but something within the computer it seems gets wacky.

    I had a new transmission put in about a year ago, would the transfer case fluid have been changed? I know the transmission/differential fluid was changed.

    If I have to, I'll change that fluid myself...never messed with it, could be empty as far as i know....is it easy to do?

  6. #6

    Default

    Quote Originally Posted by daman4469 View Post
    I had a new transmission put in about a year ago, would the transfer case fluid have been changed?
    Two separate boxes, unless instructed, I doubt the t-case fluid was changed.
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

  7. #7
    Legend

    Join Date
    Sep 2010
    Location
    everett, massachusetts
    Posts
    1,323

    Default

    the transfercase fluid is blue in color. as the fluid gets damaged it turns gray . this is when it should be replaced. the tracII GM fluid must be used. this has the proper fluid to operate this transfercase. on my 2000SIL I do this every 30-40,ooomi. at this point for me its starting to turn gray.

    the push buttons should flash 3-4 times into and out of 4wd/auto 4wd to 2WD. the longer it flashes this would indicate that the encoder motor is binding. clean fluid should fix it.

    open the top fill plug first then open the drain plug about 2-1/4 QTS required.

    use thread sealant on the plugs. torque to about 12 ft lbs. never over torque because the case WILL CRACK !

  8. #8

    Default

    Quote Originally Posted by j cat View Post
    open the top fill plug first then open the drain plug !
    Good advice @j cat, you always want to know you can put fluid in, before you take the old fluid out.
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

  9. #9

    Default

    What happened when you would push the button? Did it flash at all? Or remain solid as if you hadn't even pushed it? If it flashed, thats one thing.. But if it didn't, its most probably your selector switch on your dash... 50 bucks gets you a new one. Easy to install... My truck did the same thing... When the service 4wd light is on, I can't change it at all. Doesn't even recognize the buttons being pushed...
    00 Chevy Tahoe LT, 5.3 4x4

  10. #10

    Default

    @j_cat , excellent....I'll do it once there is a break in the weather. Good advice, and I thank you...even if it doesnt fix the issue, its probably a good thing to do anyway. @Kady , yes, my issue is quite similar. Once that 'Service 4WD' light comes on, the buttons are useless and do not respond at all. I'm thinking I may be in the same boat. However, I'm curious as to why the service light is coming on to begin with. I think jcat's idea will help with that part. (Hopefully, fingers crossed). I think it will.

Page 1 of 2 12 LastLast

Similar Threads

  1. converting 2 whel drive to 4 wheel drive
    By jdaugherty3 in forum GM Powertrain
    Replies: 15
    Last Post: 11-24-2013, 07:15 AM
  2. Loud pop when I turn the wheel in 4 wheel drive
    By Tennessee0318 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 1
    Last Post: 03-22-2012, 08:24 PM
  3. 15"X6" Steel wheel for General Motors rear wheel drive cars & trucks
    By parts bot in forum Chevy Accessories eBay
    Replies: 0
    Last Post: 11-16-2011, 06:40 PM
  4. 4 Wheel Drive
    By crane557 in forum GM Powertrain
    Replies: 2
    Last Post: 06-22-2009, 11:14 AM
  5. No Four Wheel Drive
    By quadrider52 in forum GM Powertrain
    Replies: 4
    Last Post: 02-13-2008, 08:31 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •