GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 6 of 6

Hybrid View

  1. #1
    Jr. Apprentice SAGO's Avatar
    Join Date
    Aug 2012
    Location
    San Diego, CA
    Posts
    24

    Default Starter dont click or spin

    For the past few months intermidently I would get nothing turning the key but a click at the relay. This morning she started like normal, and I stopped for coffee and smokes on my way to work. I sat in the 7-11 parking lot for 2 hours after checking relays, connections at the starter Ect. Finally I grabbed the 5/16" wrench and got a 1/2 turn out of each post. I took both terminals off and cleaned the white crusty crap off and reinstalled... She turned over like new. Hope my miss fortune helps someon
    2005 SILVERADO LS
    3" Lift Spindles
    STOPTECH Rotors
    Bilstien Shocks 4600
    AIR LIFT Air Bags
    Bridgestone Deuler REVO 2 285/70R17
    1 1/2" Wheel Spacers
    BullyDog Tuner/Gauge
    Magnaflow 3" Cat back
    K&N Air Filter

  2. #2

    Default

    Yeah, that'll get ya a few times before it becomes one of the first things you check...We all learn things better the hard way sometimes!! At least ya didn't pay to have it towed somewhere!!!
    You're driving is WAY more offensive than my swearing, assjack!!!


  3. #3
    Jr. Apprentice SAGO's Avatar
    Join Date
    Aug 2012
    Location
    San Diego, CA
    Posts
    24

    Default

    Ya no kidding!!! I'd be so pissed to pay to tow it to find a loose batt cable.

  4. #4

    Default

    Not just loose, but corroded. Both conditions are easily preventable, making the head slapping after having it towed somewhere that much more painful.
    csltrains96
    Myself, my beautiful wife
    3 - boys
    3 - minivans
    1 - '89 Chevy K2500 Silverado Truck
    1 - 27 foot travel trailer
    Not enough family time!

  5. #5
    Jr. Apprentice SAGO's Avatar
    Join Date
    Aug 2012
    Location
    San Diego, CA
    Posts
    24

    Default

    Well it did it again this morning, after finding out and fixing one issue, and knowing that wasn't the same thing, I tapped on the ingnition module that's tied to the ground cable it fired up. Thinking I'm going to have to buy something now.

  6. #6

    Default

    My truck kept doing that, I actually had to replace the terminals. Hasn't done it since.
    00 Chevy Tahoe LT, 5.3 4x4

Similar Threads

  1. We're going to spin off the Chevy Cars to a new site
    By ChevyFan in forum Chevy Car Forum
    Replies: 1
    Last: 10-03-2011, 03:30 PM
  2. Quick Spin: 2011 Chevrolet Volt - FOXNews
    By ChevyFan in forum Chevy Volt Forum
    Replies: 0
    Last: 12-10-2009, 04:10 PM
  3. front tires dont spin in 4x4
    By footballmn in forum General Chevy & GM Tech Questions
    Replies: 4
    Last: 11-04-2009, 07:59 AM
  4. 86 suburban 4wd which wheels spin?
    By aquaholic in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 5
    Last: 09-29-2008, 06:32 PM
  5. Click Here - You, reading this message, click here.
    By ChevyFan in forum The Coffee Shop ~ Chit Chat
    Replies: 1
    Last: 05-05-2005, 07:49 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •