Hi everyone, new to this forum. Working on a family member's '02 Sonoma.

2.2 Liter motor (4 cyl). No start condition. Ran well (initially after long sit), father in law parked it in afternoon, and next morning (yay) no start.

Has good spark, for good measure tried new plugs and wires.

Has good fuel pressure and volume to fuel rail... considered that may have picked up trash at injectors...

Then checked compression... 110 psi on #4 (firewall side). Cylinders 1,2,3 had ZERO compression (and yes checked multiple times and tried 2 different compression gauges wondering if shraeder valve was sticking)...

Anyways, leak down test proved air blowing out intake and exhaust like crazy, no noticeable crankcase leaking (I assumed rings were still good considering well running 24 hours previous).

So... tore cylinder head down. NOW THE QUESTION: the pushrods on the suspect cylinders 1,2,3 were pinned between the head and the rocker arms (not in their respective rocker arms' places. WHAT THE HECK HAPPENED?? Please ote the coolant level was low (about 1 gallon). COuld the hydralic lifters have "frozen" causing the pushrods to get pinned?? The Cylinder head appears in okay condition, as well as the head gasket which I thought would be the culprit.

Now the motor is torn down, please throw ANY ideas or comments my way, somewhat novice to these motors trying to brainstorm for causes, but more importantly any resulting damages and correct fix. The pushrods don't appear bent either, so replace all as precaution? I have new gasket set and reman-ed cylinder head in hand but don't want to throw it back together without proper fix.

Thanks!!!