GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 4 of 4

Thread: Strange problem

  1. #1
    Sr. Mechanic
    Join Date
    Jun 2011
    Location
    Tuscaloosa, AL
    Posts
    157

    Default Strange problem

    Hey guys so I have been having this issue for awhile now but I thought I would be able to fix it by replacing the 4 wheel drive switch. My truck has been throwing itself into 4 wheel drive randomly. I'll be driving down the road and I'll look over and the 4 low/high will be lit but not on the dash? And sometimes when this happens I also lose almost all engine power and I can barley get up any speed until I pull over and put it back into 2 wheel. What is going on with the truck? It happens randomly but sometimes at the worst time.

    Oh and this problem isn't throwing a trouble code.
    Last edited by sierra11; 12-27-2012 at 12:16 PM.
    2004 GMC Sierra SLT 6.0L 4x4
    UWS Low Profile toolbox 10% tint front and over stock back tint
    AirAid MIT and K&N airfilter
    BlackBear Performance

  2. #2

    Default

    Quote Originally Posted by sierra11 View Post
    ut I thought I would be able to fix it by replacing the 4 wheel drive switch.
    .
    I could very well be the selector switch. I can't tell from your description if you have changed it.

    If you changed it and you still have the problem, you probably need a new TCCM (transfer case control module)
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

  3. #3
    Sr. Mechanic
    Join Date
    Jun 2011
    Location
    Tuscaloosa, AL
    Posts
    157

    Default

    What I changed was the 4 wheel drive switch which is the module that houses the 4 hi 4 low, etc. A new TCCM? I'll look into that and see. What I don't understand is how is this not throwing any kind of code?
    2004 GMC Sierra SLT 6.0L 4x4
    UWS Low Profile toolbox 10% tint front and over stock back tint
    AirAid MIT and K&N airfilter
    BlackBear Performance

  4. #4

    Default

    Does the "service 4 wheel drive" light ever come on?
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

Similar Threads

  1. Strange Transmission problem?
    By Josh in forum GM Powertrain
    Replies: 3
    Last Post: 02-24-2012, 05:37 PM
  2. Strange Problem with '03 Yukon XL
    By DvlRacer in forum General Chevy & GM Tech Questions
    Replies: 1
    Last Post: 01-19-2011, 11:16 PM
  3. Strange cooling problem when freezing cold outside
    By Big6ft6 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 14
    Last Post: 04-10-2010, 03:18 PM
  4. alright... i've got a strange problem
    By twiggy in forum Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)
    Replies: 14
    Last Post: 06-03-2009, 08:45 PM
  5. Newbie with strange stalling problem
    By repo-man in forum Performance & Fuel
    Replies: 12
    Last Post: 01-02-2009, 06:31 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •