GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 2 12 Last Post byLast Post by
Results 1 to 10 of 14
  1. #1

    Default Gas gauge, heater, and wiper issues

    12/27/2012 2:29:38 AM
    Hello everyone i am named Magic.
    I am in Southwestern Ontario Canada.
    I have a`97 chev ck 1500 4x4, 4.3 L, 5 speed standard on floor
    There seems to be several issues that I cannot seem to find repairs for.
    The gas meter reads faulty , when it s emty it only reads half full, heater works only on high speed and bails out when I hit bump on the road, and wipers will only work on high speed but some times will work on intermittent if I mess with the switch a bit .
    Iíve replaced the sending unit in the gas can (well not I, but mechanic) and no change.
    Can any one give suggestive solution to any of these problems.
    I have lost some confidence in my mechanic as Iíve spent $ 600.00 into the gas can already
    Many thanks in advance
    Magic
    magic.angel@live.ca

  2. #2

    Default

    Welcome to GMTC, gald to have you here.
    1994 GMC Yukon, 2 door, Victory Red
    Garage Link: http://www.gmtruckclub.com/forum/sho...1994-GMC-Yukon

  3. #3

    Default

    Welcome!

  4. #4

    Default

    to the GMTC

    1996 Chevy Tahoe LT 5.7L V8 4X4 205,000+ miles. Built proudly at Janesville Assembly in Janesville, Wisconsin
    Basic mods: Lights all over, bunch of electrical work, and a couple cooling mods.

    Check out my other mods in My Garage: http://www.gmtruckclub.com/forum/sho...t-Tahoe-4-Door

  5. #5

    Default

    Welcome to the club, it's good to have you............ there are members on here that can help you with you issues.


    2002 Chevrolet Silverado Extended Cab SportSide: See Mods in My Garage

  6. #6

    Default

    Sounds like you may have an issue with something behind the dash. Maybe a computer connection? Or grounding issue behind the dash? Double check all connections to all the controls in the cab and make sure they are tight and well grounded. Someone else may have more experience than me. That's just my two cents.
    csltrains96
    Myself, my beautiful wife
    3 - boys
    3 - minivans
    1 - '89 Chevy K2500 Silverado Truck
    1 - 27 foot travel trailer
    Not enough family time!

  7. #7

    Default

    If the sending unit (and I say if, your words, hehe) in the gas tank is good, the stepper motor in the gas gauge is bad.

    The blower motor problem is probably the speed control resistor assembly, most of them are near the blower motor and most blower motors are accessible from under the dash, look behind the glove box.

    The wiper problem sounds like a bad switch, but there could be a broken wire under the dash, at the base of the steering column.
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

  8. #8

    Default

    Welcome from New Brunswick

  9. #9
    Jr. Engineer Jamm3r's Avatar
    Join Date
    Dec 2012
    Location
    Minneapolis area
    Posts
    240

    Default

    Quote Originally Posted by magic View Post
    12/27/2012 10:44:54 Pm
    hey everyone im new to the site and i hope im in the right spot to git some help

    Hello everyone i am named Magic.
    I am in Southwestern Ontario Canada.
    I have a`97 chev ck 1500 4x4, 4.3 L, 5 speed standard on floor
    There seems to be several issues that I cannot seem to find repairs for.
    The gas meter reads faulty , reads half full when it is empty,


    Check the ground strap between the sending unit and the frame, if missing or disconnected or corroded you will have problems like that.

    heater works only on high speed and bails out when I hit bump on the road


    Replace the blower resistor, easy fix, if it doesn't last you probably will have to replace the blower motor too, which is more difficult but if you're patient can do it in a couple hours

    and wipers will only work on high speed but some times will work on intermittent if I mess with the switch a bit .
    Put in a new switch
    Minneapolis area - 1997 K2500 regular cab long bed + 8.5' Western Unimount plow + modified transmission + 2nd battery + modified camper charge circuit + 1971 Cayo camper -and- 2004 4x4 Suburban 2500 8.1 + Maxbrake controller + 2nd battery + modified trailer charge circuit + Reese receiver, pulls 30' Airstream trailer

  10. #10

    Default

    Welcome to the G M T C ! It might help you out if you look through some of the "tech' " forums to get some ideas. Good luck!


    2010 Z/71 Colorado C/C
    Black 4X4 w/5.3L V8
    ===============
    2007 Winnebago Adventurer
    w/8.1L Chevy & Allison 6spd.
    Canyon Lake, Texas

Page 1 of 2 12 Last Post byLast Post by

Similar Threads

  1. Wiper motor issues
    By ChevyTori1997 in forum Chevy C/K Truck Forum
    Replies: 8
    Last: 04-22-2012, 10:44 PM
  2. wiper issues
    By rigo88 in forum General Chevy & GM Tech Questions
    Replies: 4
    Last: 11-04-2011, 02:11 PM
  3. 98 Silverado Windshield Wiper Issues
    By dcoperator in forum General Chevy & GM Tech Questions
    Replies: 2
    Last: 02-06-2011, 10:09 AM
  4. 04 Z71 heater issues. AC sometimes blows hot, heater temp is lukewarm
    By yak in forum General Chevy & GM Tech Questions
    Replies: 0
    Last: 11-04-2010, 10:11 AM
  5. cruise control and wiper issues
    By martin50 in forum Chevy Trailblazer Forum (GMC Envoy)
    Replies: 5
    Last: 12-11-2008, 11:58 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •