GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1

    Default 99" GMC Suburban Won't Stay Running

    hello everyone.hope for some help with problem.went to start sub and it would start but die.thought fuel pump so i changed it with oem one.ran great for 2 weeks but did exact same thing again.changed filter but didnt help.it does start and stay running sometimes.could it be engine temp sensor? thanks in advance for any suggestions

  2. #2

    Default

    I would post this in one of the tech forums it will help you get a better responce.

    Have you checked the fuel pressure and that the injectors are spraying. Also have you checked the plugs? Do you have any codes, if you do get them checked and post them here.

    1996 Chevy Tahoe LT 5.7L V8 4X4 205,000+ miles. Built proudly at Janesville Assembly in Janesville, Wisconsin
    Basic mods: Lights all over, bunch of electrical work, and a couple cooling mods.

    Check out my other mods in My Garage: http://www.gmtruckclub.com/forum/sho...t-Tahoe-4-Door

  3. #3

    Default

    I don't know your truck, but I'm guessing it has a fuel injected throttle body. A good cleaning will probably make a difference.
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

  4. #4

    Default

    99 is SFI, actually all trucks from 96 on have SFI. Cleaning the injectors still may help if they are clogged.

    1996 Chevy Tahoe LT 5.7L V8 4X4 205,000+ miles. Built proudly at Janesville Assembly in Janesville, Wisconsin
    Basic mods: Lights all over, bunch of electrical work, and a couple cooling mods.

    Check out my other mods in My Garage: http://www.gmtruckclub.com/forum/sho...t-Tahoe-4-Door

  5. #5

    Default

    Quote Originally Posted by Conlan Rose View Post
    99 is SFI, actually all trucks from 96 on have SFI.
    Thanks @Conlan Rose

    Quote Originally Posted by Conlan Rose View Post
    Cleaning the injectors still may help if they are clogged.
    Your right Conlan, it should start with dirty injectors, just run bad and maybe stall as soon as it starts, so it could be dirty injectors; but I'm wondering if gas is even getting to the injectors

    Have you checked the fuel pump relay? Can you hear the pump run?
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

  6. #6

    Default

    Welcome to the club, it's good to have you here.


    2002 Chevrolet Silverado Extended Cab SportSide: See Mods in My Garage

  7. #7

    Default

    getting misfire on 7.havent changed relay.will change plugs,wires and post results.thanks for advice everyone

  8. #8

    Default

    Quote Originally Posted by torianator View Post
    getting misfire on 7.havent changed relay.will change plugs,wires and post results.thanks for advice everyone
    Make sure you get the Delco plugs or in a year or two the same problem will come back. GM trucks love AC Delco plugs which are the OEM plugs.

    1996 Chevy Tahoe LT 5.7L V8 4X4 205,000+ miles. Built proudly at Janesville Assembly in Janesville, Wisconsin
    Basic mods: Lights all over, bunch of electrical work, and a couple cooling mods.

    Check out my other mods in My Garage: http://www.gmtruckclub.com/forum/sho...t-Tahoe-4-Door

  9. #9

  10. #10

    Default

    Quote Originally Posted by torianator View Post
    thanks conlan rose
    No problem.

    1996 Chevy Tahoe LT 5.7L V8 4X4 205,000+ miles. Built proudly at Janesville Assembly in Janesville, Wisconsin
    Basic mods: Lights all over, bunch of electrical work, and a couple cooling mods.

    Check out my other mods in My Garage: http://www.gmtruckclub.com/forum/sho...t-Tahoe-4-Door

Page 1 of 2 12 LastLast

Similar Threads

  1. Burban won't stay running
    By 2002suburban in forum General Chevy & GM Tech Questions
    Replies: 4
    Last Post: 12-23-2011, 05:26 PM
  2. Engine Won't Stay Running
    By sgenzer in forum GM Powertrain
    Replies: 2
    Last Post: 07-12-2011, 08:13 AM
  3. Suburban will not stay running
    By bublitz3 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 1
    Last Post: 10-24-2009, 11:59 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •