GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 2 12 Last Post byLast Post by
Results 1 to 10 of 13
  1. #1

    Question 2005 Silverado Intermittently Won't Start

    I have a 2005 Silverado Z71 with 5.3L engine. Runs great when it runs. Sometimes (maybe once a month) it will not start. Turn the key....nothing. No sound, gauges work, radio and lights work...just will not crank. The battery and charging system are fine. I have jiggled the gear selecter, put my foot on the brake...doesn't help. Usually if I lock/unlock the doors either by remote and/or by door switches, it fixes the problem. It can take several repeated attempts to get this to work. The computer is not throwing any error codes. Sometimes, if I just wait 10 minutes or so, it fixes itself. It is annoying, especially if I have an appointment. Mechanic won't work on intermittent issues. This has nothing to do with temperature or whether the engine is warm or cold.

    The problem seems to be in the security system (lock/unlock resets system??). I have read this same report from many other Silverado owners so it is not a unique problem. I have not found any answers other than to start replacing various parts until something works. It would seem that with so many reports of the exact same issue, there would be some part that is most likely the problem. The dealership is not helpful....they just want to rack up shop time. Any ideas?
    Last edited by Largobob; 01-02-2013 at 07:48 AM. Reason: spelling mistake

  2. #2

    Default

    It sounds, to me, like dirty connections at the battery, dirty, or loose.

    An old trick, was to turn on the headlights, this small current draw would burn off a little corrosion and then the starter would get juice.
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

  3. #3
    Legend

    Join Date
    Sep 2010
    Location
    everett, massachusetts
    Posts
    1,489

    Default

    so if you slam the doors closed it seems to clear the problem of no cranking. if so I would guess its the solenoid. I have seen this issue before. on the starter is the small solenoid wire lugs with a person holding the key in the crank position try to move these lugs on the starter solenoid. if it cranks then you have found the problem. I have found some bad solenoid connections in this area.

    most times just a slight movement will get the engine cranking. sometimes a good tap on the solenoid...

    with intermittent issues most shops will not touch it.

  4. #4

    Default

    Thanks Ray but......new battery with shiny bright/tight connections. I don't believe it is a problem with electrical power. It seems more of a deliberate cut-out device keeping the truck from cranking.

    - - - Updated - - -

    Quote Originally Posted by j cat View Post
    so if you slam the doors closed it seems to clear the problem of no cranking. if so I would guess its the solenoid. I have seen this issue before. on the starter is the small solenoid wire lugs with a person holding the key in the crank position try to move these lugs on the starter solenoid. if it cranks then you have found the problem. I have found some bad solenoid connections in this area.

    most times just a slight movement will get the engine cranking. sometimes a good tap on the solenoid...

    with intermittent issues most shops will not touch it.
    Thanks j cat. It is certainly worth a try.....and makes some sense.

  5. #5

    Default

    Run a test light from the starter signal and ground then put it under a wiper blade or tape it to the cowl. Then when it acts up if the light is on its the starter if not starter circuit.
    01' 1500 LT Z71 ECSB 5.3L
    line-x'd front brush guard with KC Daylighters, 6000k HID lows and highs, rewired highbeams, Trans-go mild shift kit, custom stainless duals, 3500 dually OEM taillights, K&N CAI. Still have OEM fender flairs and leveling kit in boxes waiting for time.


  6. #6

    Default

    Quote Originally Posted by Largobob View Post
    Thanks Ray but......new battery with shiny bright/tight connections.
    I was talking about the connectors on the ends of the battery cables (both ends, battery and starter). I have seen battery acid get under the rubber heat shrink and corrode the copper at the connector.

  7. #7

    Default

    A few things that will prevent the starter from cranking;

    1) The shift level switch is iffy. Try wiggling the shift lever in the park position. You must be on park (for safety) to crank the engine (I'm not sure about the neutral position in newer vehicles, haven't tried it in my 2012 Silver.)

    2) GM uses a smart key, (a chip embedded inside the key). Try using your other key. It could be the key or the receiver.


    https://ikeyless.com/vehicles/Chevro.../2012/1000384/
    When the key is inserted into the ignition and turned, the transponder is energized and broadcasts its unique code to the car's receiver in the dashboard. If the car's receiver recognizes the code, it will allow the car to start.

    I'm not sure it it will prevent the cranking, or allow the engine to crank and just not start (kills the ignition). Maybe someone else can answer this.

    3) The starter solenoid or the starter it self. In the starter motor's brushes or commutator are worn out, it might be stopping on a dead spot on the commutator. Usually if you tap the started motor with a hammer and it starts, replace it. It happened to me on my 2002 Astro.

  8. #8

    Default

    Passlock only shuts off the fuel, try starting in neutral and slightly moving the shifter. If it starts adjust the neutral safety switch and as last resort replace it.

  9. #9

    Default

    Quote Originally Posted by j cat View Post
    so if you slam the doors closed it seems to clear the problem of no cranking.
    As stupid as that sounds that is exactly what I have to do to get mine started. Along with intermittent starting, here are a few other symptoms that my '04 is having. Radio resets to a preset channel, if turned off it will turn back on when trying to start, fuel gauge gets stuck in position until the door is opened and then slammed. Dash lights/mirror lights flicker when the brake is depressed, electric seat "stutters" when leaving vehicle.

  10. #10

    Default

    Quote Originally Posted by emtp82 View Post
    As stupid as that sounds that is exactly what I have to do to get mine started. Along with intermittent starting, here are a few other symptoms that my '04 is having. Radio resets to a preset channel, if turned off it will turn back on when trying to start, fuel gauge gets stuck in position until the door is opened and then slammed. Dash lights/mirror lights flicker when the brake is depressed, electric seat "stutters" when leaving vehicle.
    I would say you have one, or a bunch of, bad grounds.
    Start at the battery and clean all connections, go to the other end of the battery cables and clean the connections.

    Then, crawl under the truck and find all black wires that are connected to the truck body and clean (and grease) theses connections.

    Then, pull back the carpets and look for black ground wires, clean and grease.

    With any luck, you may find the problem.

Page 1 of 2 12 Last Post byLast Post by

Similar Threads

  1. A/C blows hot to driver's side intermittently
    By stev703 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 0
    Last: 06-18-2012, 12:42 PM
  2. Brakes intermittently slow to act
    By weswins in forum Lifted & Offroad Suspension
    Replies: 2
    Last: 04-17-2011, 05:34 PM
  3. 2005 trailblaizer will not start
    By MSG G in forum General Chevy & GM Tech Questions
    Replies: 4
    Last: 12-27-2010, 12:37 AM
  4. Radio only works intermittently- 98 GMC Suburban
    By zuper8 in forum Audio, Video & Gadget Tech
    Replies: 3
    Last: 01-01-2010, 03:29 PM
  5. 2005 6.0 1500hd won't start any help?
    By pipelayer907 in forum General Chevy & GM Tech Questions
    Replies: 2
    Last: 10-12-2009, 08:09 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •