GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 8 of 8
  1. #1

    Default 1997 GMC Suburban - No 4 Wheel Drive

    Hi Guys,

    New to the forum and I have a few questions I'm hoping someone might be able to help me with.

    I recently picked-up a 1997 GMC Suburban K1500 and the electronic 4WD does not work. Previous owner is a friend and said the dealer told her the transfer case motor was bad. Not trusting the local dealer (they have a bad rap) I figured I'd do some troubleshooting before I start replacing parts. I have the GM service manuals and went through the entire troubleshooting tables to no avail. No codes stored in the 4WD switch module. Fuses good.

    The truck will not shift into 4WD - when the 4 HI or LOW button is pushed, the appropriate button blinks for a few seconds, I can hear a relay in the dash fuse panel click, I can hear the motor on the transfer case run, and it just goes back to 2WD.

    I pulled apart the transfer case motor and all seems fine - it is free and operated on +12V and -12V in opposite directions. I can hear it "work" when the 4 HI or LO button is pressed. Also checked front axle actuator - seems to work fine although maybe a little slow. I do get a brief pulse of 12V from the TC switch at the actuator when the TC motor is trying to shift to 4WD. This indicates to me that the motor is working, but perhaps it is not stopping at the correct intervals???

    Could the module be bad behind the switch panel? I hate "shot-gunning" parts as it is usually a waste of money. Trying to narrow this thing down.

    Any ideas would be appreciated!

    Matt

  2. #2

    Default

    Well if it isn't engaging then obviously something is preventing it from activating all the way. Have you checked to make sure the front diff is engaging because it if doesn't then the TC wont complete the shift.

    1996 Chevy Tahoe LT 5.7L V8 4X4 205,000+ miles. Built proudly at Janesville Assembly in Janesville, Wisconsin
    Basic mods: Lights all over, bunch of electrical work, and a couple cooling mods.

    Check out my other mods in My Garage: http://www.gmtruckclub.com/forum/sho...t-Tahoe-4-Door

  3. #3

    Default

    Conlan - Thanks for the reply. The front diff is not locking - I don't think it has a chance to. When the 4WD button is pressed, and the motor tries to shift the TC - I get a brief pulse of 12V at the front actuator. The system cycles back to 2WD so fast the front doesn't have a chance to engage. I have also read when guys have problems with the front actuator, the system says you are in 4WD but you soon discover otherwise.

    Matt

  4. #4

    Default

    Quote Originally Posted by mdmccool View Post
    I have also read when guys have problems with the front actuator, the system says you are in 4WD but you soon discover otherwise.

    Matt
    With my 95 the 4x4 indicator would not show 4x4 unless the front actuator was engaged. I had a cable actuated front actuator. So, I would put the tcase in 4x4 and not engage the diff. It would only show 2x4 until I pulled the handle. So, I do not think that the indicator would falsely show 4x4 unless the front diff was actuated.

    1995 Silverado 4x4
    6" BDS Suspension Lift-3" Body Lift-Add A Leaf in rear -Trailmaster SSV Shocks-Duel Steering Stabilizer Kit -AirAid Cold air intake-
    4.56 Gears with Detroit Auburn Locker-Pro-Comp Traction Bars with duel shocks-Aluminum Skid Plate Kit-38.5" x 16.5" Mickey Thompson Baja Claws-Constant Dropping fuel gauge

    2005 Yukon XL Jet Power Programmer, Bilstein Shocks, Bilstein rear springs, Helwig Anti-sway bars, EGR Window Visors, EGR Hood Shield, Denali Headlights, Headlight harness upgrade, GE NightHawk Bulbs, White Night Rear lighting system, Russell Braided SS brake lines, PowerStop Brake pads, PowerStop cross drilled and Slotted Rotors, http://www.gmtruckclub.com/forum/sho...5-GMC-Yukon-XL
    2002 Silverado ext cab 2wd (Sold)
    2003 Yukon XL (Totaled)

  5. #5

    Default

    Have you tried engaging it on the move. You can engage 4hi while moving and with out shifting out of drive. The problem with this era of truck is they don't have extensive 4wd codes or electronics. The system is super simple just actuators replacing manual components.

  6. #6
    Legend

    Join Date
    Feb 2008
    Location
    Red Wing, Minnesota, United States
    Posts
    3,389

    Default

    You can sit and guess and replace a lot of parts before you get the right one, many times its the switch itself that doesn't work, any GM dealership can test the 4wd system cheaply and may even waive the fee as long as you get it fixed by them, I know of some that will.
    99 K1500 Suburban LT "THE BEAST"
    Hypertech III, K&N, true dual
    285/75/16
    ___________________________
    Jason

  7. #7

    Default Encoder Motor

    Quote Originally Posted by vncj96 View Post
    You can sit and guess and replace a lot of parts before you get the right one, many times its the switch itself that doesn't work, any GM dealership can test the 4wd system cheaply and may even waive the fee as long as you get it fixed by them, I know of some that will.
    I had a similar problem as part of my "stuck in 4wd" adventure. I know your problem is the opposite but what I found could also cause your problem. Did the problem start as intermittent and slowly become permanent? Mine did. I found that the small orange wire on the encoder motor plug had corroded and broken. This wire supplies 10V+ to release the encoder motor brake. The small brown wire is ground supplied by the TCCM. If either wire is broken, the brake will not release. My motor would run while off the transfer case even though the brake wasn't released but it ran pretty slowly and got warm. When installed on the TC, it didn't have enough umph to overcome the brake and rotate the shaft to switch the TC both. My wire was broken right at the plug and I had to remove the plug from it's hanger to see the back side of it. After the wire was repaired, the motor almost snaps to change position. I think the TCCM needs the signal from the encoder that the TC has shifted to 4WD before it will engage the front axle actuator. My second problem, related, was self induced. I had plugged in the wiring to the encoder part of the motor crooked and bent two of the pins. This made my truck act exactly like yours except that I had a service 4wd light on the cluster. This was after I repaired the broken wire and I was about to start throwing things. Hope this helps. I have a 99 Suburban, a little different system but same operating principal. Electric shift TC, TCCM, encoder motor, axle actuator. Maybe check fuses too. There should be two. One for the encoder motor, I think the fuse cover calls this one the transfer case fuse (#2 in my '99). The other is called the 4wd fuse (#24 in mine). Good luck.

  8. #8
    Newbie
    Join Date
    Oct 2009
    Location
    West River, MD & Fort Lauderdale, FL
    Posts
    7

    Default Check electrical connections

    Had problem with 4wd on my 97 K1500- pushed 4Hi & light would blink, heard things whirring/clicking but would never indicate 'engaged'. Of course, found this out when 4wd was needed & had to resort to ropes & come-alongs. Turns out the transmission fluid that has been leaking out of tranny case crack (2nd time in 3 mos on rebuilts, but that's another story) had gotten into the contacts/connectors & after a complete bath with brake cleaner (5 cans on underside of vehicle), the 4x4 started working again- engaged properly, etc. May want to check for fluid invasion- first failure of the trans case/fluid leak had caused a brand new O2 sensor to fail as well- cleaning of the connection solved.

Similar Threads

  1. converting 2 whel drive to 4 wheel drive
    By jdaugherty3 in forum GM Powertrain
    Replies: 15
    Last: 11-24-2013, 07:15 AM
  2. Loud pop when I turn the wheel in 4 wheel drive
    By Tennessee0318 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 1
    Last: 03-22-2012, 08:24 PM
  3. 15"X6" Steel wheel for General Motors rear wheel drive cars & trucks
    By parts bot in forum Chevy Accessories eBay
    Replies: 0
    Last: 11-16-2011, 06:40 PM
  4. 2000 Chevrolet Suburban 1500 2 wheel drive / Vent Valve and Fuel pump problem
    By charlieetzel127 in forum General Chevy & GM Tech Questions
    Replies: 1
    Last: 08-20-2010, 02:01 PM
  5. Help 96 suburban k1500 stuck in 4 wheel drive
    By Pmont in forum GM Powertrain
    Replies: 3
    Last: 08-06-2010, 02:40 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •