GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 8 of 8
  1. #1

    Default Electrical issue?

    Hey guys, whats the best way to test the electrical system on my 94k1500. I have been noticing that when I have all my accessories on (defroster-full blast, headlights, and radio) my amps gauge is close to 9 when it should run around 14. When I brake or use my blinkers, its goes even lower. I have a brand new battery (3 months) and my alternator test positive. Any suggestions?

    Also, I dont know if this is electrical related, but my horn sounds weak. Its a very low pitch sound. When I honk the horn, its drops my amps as well.
    Last edited by jsmith4816; 01-04-2013 at 08:31 PM. Reason: Grammar
    -K&N Air Filter


  2. #2

    Default

    You are either putting to much draw on the electrical system or the electrical system is not working at peak efficiency Are all your connections to the battery and alt tight and sound. How old is the alt and what amperage? Is the connections to the under hood fuse box all good? All I know is there isn't enough power flowing through your system.

    I have never had a problem with this even when the running blower at max, rear defrost on, all lights on, radio blaring and the truck only at idle in the cold. Btw it is a voltmeter not a amp gauge. It detects the overall voltage of the system. At any point below 12.6 the battery light usually comes on.

    1996 Chevy Tahoe LT 5.7L V8 4X4 205,000+ miles. Built proudly at Janesville Assembly in Janesville, Wisconsin
    Basic mods: Lights all over, bunch of electrical work, and a couple cooling mods.

    Check out my other mods in My Garage: http://www.gmtruckclub.com/forum/sho...t-Tahoe-4-Door

  3. #3

    Default

    @Conlan Rose pretty much covered everything I'd have considered asking/saying.

  4. #4

    Default

    The alternator keeps the battery charged and under "normal" conditions, provides the electrical needs of the truck.

    The role of the battery (after starting the engine) is to provide a power reserve when the alternator can not provide sufficient power.

    To accomplish the above, all connections must be clean and tight.

    Your description makes me suspect the new battery; however, that's just a guess without test data. You need to have the battery and the alternator load tested.

    BTW, the gauge in the dash reads volts, not amps, not a big thing, but good to have the right terms when you talk to a shop about the lead testing. Good luck
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

  5. #5

    Default

    Thanks guys, learning as i go!

  6. #6

    Default

    It was a ground. The one right next to my battery. Still going to get a load test done. My truck being this old, I would rather find out if something is wrong now, then find out the hard way. That am I am kind of a rookie when it comes to anything electrical related, lol

  7. #7

    Default

    If you still have the same symptoms after fixing the ground and having everything load tested, I'd say you simply need a larger alternator. My two cents.
    csltrains96
    Myself, my beautiful wife
    3 - boys
    3 - minivans
    1 - '89 Chevy K2500 Silverado Truck
    1 - 27 foot travel trailer
    Not enough family time!

  8. #8

    Default

    Update: It was the alternator. Had it tested and they said whenever i am driving the alternator is charging but when I stop, thats when it fail. Should explain why it feels like it wants to stall out when I am stopped. I have a lifetime warranty on the alternator from Auto Zone, so should be a quick fix. However, I just need the weather to work in my favor.

    Once again, thanks for all the help and/or suggestions.

Similar Threads

  1. electrical issues?
    By nitz0422 in forum General Chevy & GM Tech Questions
    Replies: 4
    Last: 01-06-2012, 10:59 AM
  2. Electrical Issues
    By horsemanmike in forum GM Electrical Tech
    Replies: 3
    Last: 07-22-2011, 09:44 AM
  3. Electrical Issues
    By focal318 in forum General Chevy & GM Tech Questions
    Replies: 2
    Last: 08-29-2009, 10:57 PM
  4. Electrical Issues
    By ChevyFan in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 10
    Last: 12-03-2008, 08:52 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •