GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 9 of 9
  1. #1

    Default 97 gmc 4.3 electical problems

    i have a 97 gmc 4x4.have replace motor and bout all the sensors.now having an electrical problem.some sensors test good with test light and some dont....really need some help please

  2. #2

    Default

    I think that we may need some more information! What sensors are testing bad? How are you testing them with a light? Not all sensors will test "ok" with a test light. What codes are you getting? The codes could help track down the issue.

    1995 Silverado 4x4
    6" BDS Suspension Lift-3" Body Lift-Add A Leaf in rear -Trailmaster SSV Shocks-Duel Steering Stabilizer Kit -AirAid Cold air intake-
    4.56 Gears with Detroit Auburn Locker-Pro-Comp Traction Bars with duel shocks-Aluminum Skid Plate Kit-38.5" x 16.5" Mickey Thompson Baja Claws-Constant Dropping fuel gauge

    2005 Yukon XL Jet Power Programmer, Bilstein Shocks, Bilstein rear springs, Helwig Anti-sway bars, EGR Window Visors, EGR Hood Shield, Denali Headlights, Headlight harness upgrade, GE NightHawk Bulbs, White Night Rear lighting system, Russell Braided SS brake lines, PowerStop Brake pads, PowerStop cross drilled and Slotted Rotors, http://www.gmtruckclub.com/forum/sho...5-GMC-Yukon-XL
    2002 Silverado ext cab 2wd (Sold)
    2003 Yukon XL (Totaled)

  3. #3

    Default

    Quote Originally Posted by Pikey View Post
    I think that we may need some more information! What sensors are testing bad? How are you testing them with a light? Not all sensors will test "ok" with a test light. What codes are you getting? The codes could help track down the issue.
    x2. we need to know what your issue is
    "i dont think you got the picture. i got a beautiful picture. this baby happens to have an extra turn of speed, which is the only thing i care about. you dont understnad what happens do you? they make cars. they make 'em exactly the same way. one or two of 'em turn out to be something special. nobody knows why. i know why. i may be kiddin' myself, but i think i can make somethin' out of that sad little bucket of bolts." ~ Tennessee Steinmetz

  4. #4

    Default

    Welcome to the club, it's good to have you here.


    2002 Chevrolet Silverado Extended Cab SportSide: See Mods in My Garage

  5. #5
    Legend


    mfleetwood's Avatar
    Join Date
    Jul 2010
    Location
    Denver, CO
    Posts
    7,213
    Blog Entries
    1

    Default

    I moved your thread to the correct forum section and enhanced your thread title so that it more describes the category of problem you are having.

    Welcome to the Club and good luck in getting your issues solved.


    Mike (Denver, CO) - 2008 Sierra 1500 Z71 SLE 5.3L 4WD

    SUSPENSION: Rancho 4" Suspension Lift; Rancho RS9000XL Shocks; Rancho Skid Plates; Rancho MyRide Wireless Shock Controller;
    TIRES:
    BFG All Terrain KO 315/70/17
    DRIVE TRAIN: 4.56 Gears; Detroit TrueTrac Differential; True Cool 40k Transmission Cooler
    PERFORMANCE: DiableSport Predator Tuner; Custom Tuned by Diablew; Magnaflow Exhaust; AFE Cold Air Intake
    ELECTRONICS: Kenwood DNX6180 Touchscreen; Subthump box w/10" Kicker; Driver Information Center (DIC); Rear View Camera
    ACCESSORIES: Westin Brush/Grill Gaurd; Westin Nerf Bars; Truxedo Tonneau; 20% Tint; Tow Mirrors w/Heat & Signals

  6. #6

    Default

    getting codes for oxygen sensor and catalyst not ready,truck runs great untill its warmed up.cruising around 60 mph then it jerks

  7. #7

    Default

    You replaced the o2 sensors?



    If at first you don't succeed, chances are, you are using too small of a cheater bar

    Current:
    1999 GMC Sierra SLT Z71 | 5.3 Vortec | Spectre Cold Air Intake | TransDapt TBS | Hypertech 30005 Tune | 2005 Chevy Tails | Denali headlights | AWS Bug Shield | 265/75/16 Mastercraft Courser A/T | "Ghetto" painted tailgate | Boss HD Speakers | 2005 Overhead Console | Dual Thrush Turbo Mufflers
    Future:
    Bigger Amp Alternator | Electric Fans | Oil/Trans Fluid cooler | Re-done exhaust | Paint | Interior Restoration/upgrade with newer model stuff | Window Visors (In channel) | Tint | Low-Profile Tool Box | LEDs throughout stock cab locations | And whatever is spurr of the moment
    US Navy Sailor :sign0011:

  8. #8

    Default

    When cold, the PCM uses a programmed set of fuel/air mix instruction tables (open loop). When the engine gets warm, the PCM switches to the O2 sensors to tell the PCM the ratio that is needed (closed loop).

    If it runs "bad" when warm, you probably need new O2 sensors (just the front ones, the rears are to test the cat).
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

  9. #9

    Default

    The heater circuit may be bad or crossed signal wires, scan it when running bad and go to data and tell us the voltage of the upstream (1/1,1/2) sensors. They should bounce up and down consistantly. You can use a light to test the heater circuit but DO NOT , repeat DO NOT SHORT THE HEATING AND SENSOR CIRCUITS, WILL FRY THE COMPUTER! What i use is a low beam headlight with socket to test both power and load test the wires, if it starts bright then dims there is a bad connection somewhere, no light no power.
    01' 1500 LT Z71 ECSB 5.3L
    line-x'd front brush guard with KC Daylighters, 6000k HID lows and highs, rewired highbeams, Trans-go mild shift kit, custom stainless duals, 3500 dually OEM taillights, K&N CAI. Still have OEM fender flairs and leveling kit in boxes waiting for time.


Similar Threads

  1. 2007 Suburban Instrument Panel Goes Out / Electical Problem
    By tomtina1 in forum GM Electrical Tech
    Replies: 3
    Last Post: 09-30-2010, 05:19 PM
  2. few questions, electical on 75 burban 454
    By bldeagle10 in forum General Chevy & GM Tech Questions
    Replies: 2
    Last Post: 12-26-2009, 07:13 PM
  3. Electical issues after installing CB
    By Dementia in forum General Chevy & GM Tech Questions
    Replies: 4
    Last Post: 06-30-2009, 08:16 PM
  4. 09 Suburban electical question
    By mballes in forum Audio, Video & Gadget Tech
    Replies: 0
    Last Post: 05-26-2009, 03:12 PM
  5. moisture in electical system
    By Jamesbo in forum General Chevy & GM Tech Questions
    Replies: 0
    Last Post: 01-07-2009, 10:20 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •