GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 2 12 LastLast
Results 1 to 10 of 12
  1. #1

    Default Help! 97 wont start

    When i turn the key nothing! Acts like it would as if it was in gear and you where trying to start it. Lights all come on the dash but it just wont crank. I am thinking neutral safety switch? Anyway to check it? To make matters worse, i don't have a manual...where the heck is it located? Any input is appreciated.


    1997 5.7L
    1997 Gmc Suburban SLT
    178k 2wd

  2. #2
    Legend tlperry68's Avatar
    Join Date
    Oct 2008
    Location
    Huntington Beach, CA
    Posts
    1,504

    Default

    I think its the switch too or maybe a solenoid. Try running the gear selector lever through all the gears and put it back in park. If nothing try to put the lever in neutral.
    Trevor - Huntington Beach, CA
    2007 GMC 2500 4X4

  3. #3
    Jr. Mechanic
    Join Date
    Dec 2008
    Location
    Gettysburg, Pa.
    Posts
    103

    Default 97 won't start

    Don't forget to check fuses.

    Do the lights dim at all when you turn the key to start?

  4. #4

    Default

    make sure the positive terminal are clean and tight the have a habit of not making good contact

  5. #5
    Legend

    Join Date
    Feb 2008
    Location
    Red Wing, Minnesota, United States
    Posts
    3,356

    Default

    i would start making sure all contacts are thoroughly cleaned, including sown to the starter. When that ets corroded it can give you all kind of different symptoms, that would make it seem like the battery or otherwise.
    99 K1500 Suburban LT "THE BEAST"
    Hypertech III, K&N, true dual
    285/75/16
    ___________________________
    Jason

  6. #6

    Default

    Quote Originally Posted by mrfixdit View Post
    Don't forget to check fuses.

    Do the lights dim at all when you turn the key to start?
    the lights dim just as if it would start but nothing else happens. I just had a new battery installed (last week) and they ran a test on the alternator and the starter...both checked out ok. I ran the gear selector up and down the gears and tried the start from neutral but no go. Any one ever have issues with the safety switch?
    1997 Gmc Suburban SLT
    178k 2wd

  7. #7
    Legend

    Join Date
    Feb 2008
    Location
    Red Wing, Minnesota, United States
    Posts
    3,356

    Default

    Well if you had the bettery changed then I would for sure be checking connections then, it could be time to just replace the wires for the battery going to the starter, any little bit of cossosion that can creep up the insulation will cut the power
    99 K1500 Suburban LT "THE BEAST"
    Hypertech III, K&N, true dual
    285/75/16
    ___________________________
    Jason

  8. #8

    Default

    Do you hear a click of the starter solenoid? If so, then you have a bad starter. Usually hitting it with a hammer while someone tries to start it will get it to go. If you don't notice any clicks of the solenoid then you have a bad fuse or wiring/connectivity issue. If you have had the lights dimming while trying to start it then you know the car thinks it's in park or neutral, so you can rule out the safety switch!

  9. #9
    Jr. Mechanic
    Join Date
    Jan 2009
    Location
    Elizabeth City, NC
    Posts
    75

    Default

    Try jumping the two terminals on your solenoid under the hood while someone is trying to crank it. Be careful to not get shocked. I usually use a big screw driver and touch the terminals together. That would tell you if it is actually getting to your starter.

  10. #10

    Default

    Well went over to work on her today...she cranked right up! so...i am assuming i need to replace the starter solenoid and i may as well do the battery cables while i am at it.
    1997 Gmc Suburban SLT
    178k 2wd

Page 1 of 2 12 LastLast

Similar Threads

  1. wont start sometimes
    By roninbrad in forum GM Powertrain
    Replies: 1
    Last Post: 06-25-2010, 11:48 PM
  2. Still wont start
    By Allmostsmart in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 6
    Last Post: 04-08-2010, 07:59 PM
  3. truck wont start.........
    By NORMSCOLORADO in forum Chevy C/K Truck Forum
    Replies: 4
    Last Post: 04-08-2010, 01:09 PM
  4. wont start
    By jprimrose4292 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 12
    Last Post: 06-11-2009, 10:56 AM
  5. 93 Suburban1500, 350, 5.7L Wont Start
    By SChevyTeamS in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 1
    Last Post: 03-20-2009, 03:44 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •