GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 2 of 2
  1. #1

    Default 03 Yukon T/C issue

    as the title says i have an 03 yukon xl with a bit over 300000 km on it, i bought it 3 years ago
    first year was fine, then the traction control started engaging for no reason (even on dry pavement with light throttle) about once a month
    as time went on the problem became more frequent however going into the next winter the problem totally disappeared even on snowy and icy roads
    the following spring the problem came back, it did seem the colder it was the less frequent the problem, however now its happening 99.9999999% of the time regardless of the temp
    so as i accelerate and get to about 5 or 10 km/h i let off the gas for a sec then continue to accelerate and its fine till i stop again or just push the button to disengage the t/c
    through all this time there are no warning lights or codes at all (at least codes i can read, never had a dlr scan it, didnt want to spend 100+)
    oh also no abs codes or problems with abs
    so i have 2 questions, what could the problem be ?
    is there a way to remove a fuse or relay to disengage the system so i dont have to push the button all the time
    if it matters, its awd with 5.3L
    also if it matters, all fluids have been changed, also l/f hub was replaced too
    thanks for any help

  2. #2
    Legend

    Join Date
    Feb 2008
    Location
    Red Wing, Minnesota, United States
    Posts
    3,386

    Default

    One of your abs sensors has failed or could be dirty or even disconnected, they can fail and give no code. I would try pulling them all and just visually checking he connections and wiring. Otherwise I am sure a dealership will have to test them to find out what's really going on
    99 K1500 Suburban LT "THE BEAST"
    Hypertech III, K&N, true dual
    285/75/16
    ___________________________
    Jason

Similar Threads

  1. 2011" Yukon XL 2500 Rough Idle/Power Issue.
    By Ehren in forum General Chevy & GM Tech Questions
    Replies: 4
    Last: 11-27-2012, 07:38 PM
  2. Replies: 0
    Last: 10-18-2012, 01:20 PM
  3. AC Issue and Temp Control 2003 Yukon
    By gripper in forum Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)
    Replies: 1
    Last: 04-19-2012, 05:19 PM
  4. Replies: 0
    Last: 02-20-2012, 12:29 PM
  5. 02 Yukon SLT 5.3L Flex Fuel, fuel line issue
    By TRyan9441 in forum Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)
    Replies: 2
    Last: 06-02-2011, 12:19 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •