GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 5 of 5
  1. #1
    Sr. Engineer FergusonT's Avatar
    Join Date
    May 2010
    Location
    Southwest Michigan
    Posts
    398

    Default '99 Silverado ---No Flashers

    The other day I am hauling some straw/hay from down the road and I am running with the hazards on. Sometime down the road the hazards stop, no turn signals either. I check all the fuses and replace a couple that were blown, don't even remember what they were for but they were unrelated to the flashers.

    I also replaced the flasher relay today, still nothing. Multi function switch. The cruise, wipers, brights, all the lights work fine. Just no turn signals/hazards.

    Luckily I have all back roads to work, but I do get the occasional county boy behind me.

    - - - Updated - - -

    Actually now I remember replacing a 10amp fuse with a 20 amp fuse, something to do with trailer lights. So maybe that fried the multi function switch.
    1999 Chevrolet Suburban LS K1500
    1991 Chevrolet S10 4.3L 4x4
    2005 Suzuki Forenza (GM/Daewoo)

  2. #2
    Sr. Engineer FergusonT's Avatar
    Join Date
    May 2010
    Location
    Southwest Michigan
    Posts
    398

    Default

    anybody have any thoughts?

  3. #3

    Default

    Could be the switch, but check all your grounds too.



    If at first you don't succeed, chances are, you are using too small of a cheater bar

    Current:
    1999 GMC Sierra SLT Z71 | 5.3 Vortec | Spectre Cold Air Intake | TransDapt TBS | Hypertech 30005 Tune | 2005 Chevy Tails | Denali headlights | AWS Bug Shield | 265/75/16 Mastercraft Courser A/T | "Ghetto" painted tailgate | Boss HD Speakers | 2005 Overhead Console | Dual Thrush Turbo Mufflers
    Future:
    Bigger Amp Alternator | Electric Fans | Oil/Trans Fluid cooler | Re-done exhaust | Paint | Interior Restoration/upgrade with newer model stuff | Window Visors (In channel) | Tint | Low-Profile Tool Box | LEDs throughout stock cab locations | And whatever is spurr of the moment
    US Navy Sailor :sign0011:

  4. #4
    Sr. Engineer FergusonT's Avatar
    Join Date
    May 2010
    Location
    Southwest Michigan
    Posts
    398

    Default

    When I was underneath the dash I noticed a lot of stuff was loose under there. When I got the truck it had a trailer brake controller hooked up, and it looks like maybe they took a lot of stuff apart underneath when they installed it. Doesn't really look like it i was put back together right.

  5. #5

    Default

    Sounds like it might be the switch i had a ranger that did that

Similar Threads

  1. Turn Signals and flashers not working in '02 Chevy Silverado 2500HD
    By JulieMcD in forum General Chevy & GM Tech Questions
    Replies: 5
    Last Post: 08-14-2010, 02:27 PM
  2. Problems with flashers. k1500 1997
    By kungen08 in forum Chevy C/K Truck Forum
    Replies: 2
    Last Post: 10-31-2009, 10:43 AM
  3. Brake, Turn signals, and emergency flashers
    By da pope in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 13
    Last Post: 04-25-2009, 03:45 PM
  4. Brake lights/Flashers ????????? [Expired Topic]
    By rt1092 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 5
    Last Post: 07-21-2006, 08:28 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •