GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 10 of 10
  1. #1

    Default 1999 Suburban Steering Wanders Problem

    1999 Chevy Suburban, 2500, 4wd, 7.4 liter, 164,500 miles. I have a loose steering and vehicle wandering problem that my front end guy canít figure out. Itís a reputable shop that was recommended to me by a friend. The shop owner is convinced that my new Michelin tires are the cause of the problem.

    Hereís the story. Last September I needed a new set of tires. The existing set of tires was a cheaper tire that eventually became out of round and could not be balanced. The entire vehicle shook very badly at 64 to 76 mph. I figured I had learned my lesson, so I went with a set of new tires, Michelin, LT265/75R 16M/S 2. The steering did not wander prior to the new tires. This is a slightly larger tire than what came on the truck from the factory. According to the optional equipment for this truck, you could have ordered this size tire from GM. I still had a vibration problem after the new tires and got a lot of run-a-round from the tire store.

    After the third time the guys at the tire shop told me it was fixed and not vibrating, I took the service tech and write up guy for a ride, where we were able to confirm what I was complaining about. It turns out that they had to balance a set of newer rear brake drums that were put on during a 4 wheel brake job in Sept of 2010 (146,800). As an aside, the rear brakes had to be redone in January 2011 due to leaking rear axle seals. The drums were turned then too (156,708). Oh by the way, the tire shop tried a another new set of drums and found those were more out of balance and said they caused an even worse vibration problem than the existing set of drums. Seems pretty strange to me. Anyway, basically the vibration problem has been fixed, but now the truck wanders around like I've had a few too many even after sinking another big chunk of cash into it. The front end shop owner says the front end is tight and is in factory spec alignment.

    Have you ever heard of a set of tires displaying this problem? Any ideas what the problem might be? How do I identify it, or help a shop identify it? And if it is the tires, how do I convince the tire shop itís the brand new Michelin tires?

    Please help. Thanks. Kurt

    Here's a rundown of the work that's been done in the last few years and up to the present.
    And on another note, any ideas about these axle seals and/or why I keep eating sets of brakes?


    1-17-13, 164,000
    Realign front end.

    1-3-13, 163,628.
    Remove rebuilt steering gear box. Replace with GM/Delco rebuilt steering gear.

    Front end alignment
    8-17-12. 161,932.
    Rebuilt steering gear box.

    EVO refit.
    Front end alignment.
    8-15-13, 161,800
    R & R Upper Control Arm Bushings, R + L

    R & R broken front anti-sway bar links/bushing.
    Front end alignment.
    7-27-13, 161,190
    4 Michelin LT265/75R 16M/S 2

    Hunter Variation Force Balance tires.
    Balance rear brake drums.
    7-26-13, 161,156
    R & R RF Lower Ball Joint.

    Front end alignment.
    1-27-11. 156,708
    R & R LR Axle Seal

    R & R Rear Brake Shoes, Hardware, & Self-adjuster.
    Machine rear brake drums.
    11-18-10, 150,174
    Clean, adjust rear brakes.

    Machine rear brake drums.
    9-14-10. 146,800
    R & R Front brake pads & rotors.

    R & R Rear brake shoes & drums.
    Adjust rear brakes.
    4-29-10. 136,502
    R & R LF Upper and Lower Ball Joints

    R & R L CV/Axle Shaft
    Front end alignment.
    4 Wheel Balance.

  2. #2

    Default

    Jack it up and shake the front wheels back and forth to see if there's any slop. The rebuilt gear box raises a flag for me. If that's not it, you might look at the intermediate shaft between the column and gear box to see if it's got any play.
    ...
    ....

  3. #3

    Default

    Does it wander when your accelerating, braking, or just cruising? How about your shocks? When was the last time those were changed?
    00 Chevy Tahoe LT, 5.3 4x4

  4. #4
    Sr. Apprentice
    Join Date
    Nov 2009
    Location
    Grandview, WA
    Posts
    68

    Default

    What about your steering sensor, i replaced mine when it wondered. Now its fine.

  5. #5

    Default

    Thanks for your replys.

    Steering intermediate shaft has no play. No U joints in the assembly. I'm told it's just a rag joint, but I haven't inspected it myself yet.

    Wanders all the time. Shocks are about 4 years old and I replaced them with the stock Bilstein's that were on it. What would shocks have to do with a wandering problem anyway?


    Steering sensor? What steering sensor? What does it sense? Why? Does this vehicle have a steering sensor? Are you referring to the EVO? Which brings forth another question...
    Did these steering gear boxes even have an EVO?

    Anyway... here's what happened. Shook down the front end again at yet another shop. Guess what? Left uppper ball joint, which had only 30,000 on it, was loose with a broken stud. I immediately went back to the first place and asked the shop owner (where all this front end work was done) about it, and of course he denied that he spun it when he did the upper control arm bushings. He was, again of course, willing to fix for $ 215.00, plus the cost of another alignment. No wonder he had trouble getting it into alignment and no wonder he failed to mention that until I started asked pointed questions. I told him no thanks and left. Just another greedy, lying, cheating thief. At the best, he's incompetent. Bad on me for trusting the guy in the first place.

    I forgot to mention the new Pittman Arm and Idler Arm he sold me (that I didn't need).

  6. #6
    Sr. Apprentice
    Join Date
    Nov 2009
    Location
    Grandview, WA
    Posts
    68

    Default

    http://www.oreillyauto.com/site/c/se...teering+sensor

    This is the link to show what a steering wheel sensor looks like.

  7. #7
    Jr. Mechanic
    Join Date
    Sep 2007
    Location
    Los Angeles, CA
    Posts
    116

    Default

    Quote Originally Posted by Chris Miller View Post
    Jack it up and shake the front wheels back and forth to see if there's any slop. The rebuilt gear box raises a flag for me. If that's not it, you might look at the intermediate shaft between the column and gear box to see if it's got any play.
    A lot of wandering issues are caused by tie rod end or idler arm wear. Also, do you have a steering stabilizer on your truck? I can not remember on 99s. And it could very well be your shocks if they are 4 years old. Worn shocks could have caused your last set of tires to go out of round as well. Good luck. Hope this helps.
    '88 Jimmy 4X4
    5.3l L59/ 4L60E Tuned by Tad
    4" Lift 33" BFG. Custom Brush Guard, KCs, outside spare, Oil pan guard etc.

  8. #8

    Default

    I have to agree with jedepsub that the steering sensor can cause a wandering, loose feeling in the steering. I replaced it on my 1999 Tahoe and it fixed my problem. After I changed out a badly worn pitman arm and a slightly worn idler arm, I continued to notice some looseness, darty feeling in the steering. Please don't misunderstand me, there was a huge improvement after replacing both the pitman and idler arms, but it still didn't feel 100%. It was a tip on this forum to check into a bad steering sensor that led me to replace it, and it did the trick. FYI - If you decide to replace the sensor, search around for the best price as there can be quite a difference between suppliers.

  9. #9

    Default

    It didn't hurt to replace the P arm and I arm while he had it apart, as those can be costly if they go bad. i think i would take the guy to small claims, just to teach him a lesson in honesty.

  10. #10

    Default

    I know this is an old thread, but I have the same truck and had the same exact issues. After 3 alignments and tons of new suspension and steering parts (and many baffled mechanics) I decided to pull the steering shaft myself and have a look see. My rag joint was torn to shreds. I slapped a new one on and had perfect steering for the first time ever (I bought the truck with the loose steering.) I'm running on 265/70/17 MT all terrains and when the rag joint was in shreds, I ate thru two sets of tires within 1 year. I have since gone thru a rag joint about every 9 months. While I get their plan for them (soaking up some of the road vibrations and such) I do not believe they are appropriate for these 2500 7.4's with such a heavy front end. My truck eats right thru those rubber joints. I'm thinking about replacing it with a flaming river Ujoint, but haven't found one that's not compete with the shaft for my make and model. I was excited to see some conversation on this topic with the 99/2500/7.4 so I had to register! It's pretty tough finding info on these trucks online!

Similar Threads

  1. '99 3/4 suburban power steering problem
    By Mike Was in forum Chevy SUV & Crossover Tech Forum
    Replies: 1
    Last Post: 09-27-2012, 11:08 PM
  2. Weird steering problem 98 GMC suburban.
    By My98Suburban in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 2
    Last Post: 01-14-2012, 08:02 PM
  3. 99 suburban steering wheel problem
    By Hololio5 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 1
    Last Post: 05-26-2010, 11:31 PM
  4. 1999 Suburban Steering Clunk
    By alkmisc in forum Lifted & Offroad Suspension
    Replies: 2
    Last Post: 02-11-2010, 01:47 PM
  5. Steering very squirrely and wanders? Need help
    By hollywood13185 in forum Lifted & Offroad Suspension
    Replies: 0
    Last Post: 12-06-2009, 07:43 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •