GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1

    Default I Bought a '95 TBI 5.7L with "resistors" stubbed into the injector power leads...WTH?

    Greetings -

    As stated in the title, I bought my '95 Suburban with what looks to be resistors (fusible links?) wired into each injector. I'll try to get a photo posted as soon as possible, to show exactly what I am describing. In the meantime, has anyone ever heard of such a thing? If so, why? I've been stumped for a while now. The truck has a 'stumble' @ idle, under forward / reverse gear mode while at a stop...could these be reason for the 'stumble'? I've posted a picture in my 'Garage' area, under the 'Under the hood' category. Any ideas? Crazy I tell ya...
    Last edited by Dana Joe; 01-25-2013 at 05:16 PM.
    Dana Joe
    Phoenix, AZ
    HOOK 'EM HORNS!

  2. #2

    1995 Silverado 4x4
    6" BDS Suspension Lift-3" Body Lift-Add A Leaf in rear -Trailmaster SSV Shocks-Duel Steering Stabilizer Kit -AirAid Cold air intake-
    4.56 Gears with Detroit Auburn Locker-Pro-Comp Traction Bars with duel shocks-Aluminum Skid Plate Kit-38.5" x 16.5" Mickey Thompson Baja Claws-Constant Dropping fuel gauge

    2005 Yukon XL Jet Power Programmer, Bilstein Shocks, Bilstein rear springs, Helwig Anti-sway bars, EGR Window Visors, EGR Hood Shield, Denali Headlights, Headlight harness upgrade, GE NightHawk Bulbs, White Night Rear lighting system, Russell Braided SS brake lines, PowerStop Brake pads, PowerStop cross drilled and Slotted Rotors, http://www.gmtruckclub.com/forum/sho...5-GMC-Yukon-XL
    2002 Silverado ext cab 2wd (Sold)
    2003 Yukon XL (Totaled)

  3. #3

    Default

    That's obviously not factory. Why it was put there, I have no idea. It looks like it might actually be a capacitor. Perhaps the previous owner put them there to lengthen the injector pulse as a power adder. Does it work? I dunno. Those injectors use a peak and hold strategy to operate.
    Christopher

    1991 Chevy Suburban 1/2 ton 2WD w/ chevy SBC 350-3/4 ton drivetrain upgrade w/4.10 gears 200K miles
    2005 Saturn ION-2 Stock 265K miles
    1982 Bronco, 1993 Bronco (sold), 1971 M35A2 Deuce and a Half



    There are 10 kinds of people, those who understand binary, and those who dont...

    Remember kids, the only difference between screwing around and science is writing it down- Adam Savage

  4. #4

    Default

    Other than the 'stumble' I described, yeah...they work fine.

    Then again, could this be a cause for the 'stumble' I am experiencing?

    Thanks for your reply!
    Dana Joe
    Phoenix, AZ
    HOOK 'EM HORNS!

  5. #5
    Legend
    TRPLXL2's Avatar
    Join Date
    Jan 2009
    Location
    Norwalk, Ohio
    Posts
    3,359
    Blog Entries
    8

    Default

    I was pretty confident I knew what you were talking about, and then I saw the picture and I went WTH??? GM does use "heat sinks" on a lot of there engine harnesses, but they look nothing like that. I would agree that it is something aftermarket.
    2004 Chevy Colorado
    LS1 5.7 swap/TBSS rear axle swap

  6. #6

    Default

    If you can get a closer picture of one of those blue components, whatever they are, I can try to tell you more about why they may be there. I can't read the number in your existing picture.
    Christopher

    1991 Chevy Suburban 1/2 ton 2WD w/ chevy SBC 350-3/4 ton drivetrain upgrade w/4.10 gears 200K miles
    2005 Saturn ION-2 Stock 265K miles
    1982 Bronco, 1993 Bronco (sold), 1971 M35A2 Deuce and a Half



    There are 10 kinds of people, those who understand binary, and those who dont...

    Remember kids, the only difference between screwing around and science is writing it down- Adam Savage

  7. #7

    Default

    They look like capacitors. Capacitors are used with relays to "capture" the back emf, turning the relay into a "slow release" relay. As @Crawdaddy suggested, perhaps to lengthen the pulse.
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

  8. #8

    Default

    Thanks guys - I will try to get a better photo tomorrow. If the numbers that are printed on these "devices" aren't legible in the photos, I'll be sure to include them in the text of my next post.
    Dana Joe
    Phoenix, AZ
    HOOK 'EM HORNS!

  9. #9

    Default

    Those are capacitors, I don't remember the name of the company, heck I don't even think their in business anymore either.
    Those are part of a performance kit that supposedly boosted performance and mileage, the idea was to pulse the output of the injectors, instead of a straight shot of fuel these capacitors would shoot, pause, shoot allowing time for first shot of fuel to vaporize before shooting the second shot in. I Don't think the idea caught on or really did very much for performance.
    The kit also had a piggyback chip that plugged in on the ECM, they could run without the ECM chip though, not sure what it's purpose was.
    Those capacitors came in two or three modes, I know one mode was a two shot pulse, another mode was a three shot pulse, and i believe the third mode was an extra long pulse that kept the injector open longer than the factory time frame.

  10. #10

    Default

    Thanks, Tim! I haven't checked to see if there is any kind of chip installed in the vehicle; would I be able to tell anyway? None the less, with the timing reset to factory spec's, I've noticed my mileage go up, but also a drop in off-the-line power. I recently had the distributor assembly replaced at a buddy's shop - unbeknownst to me, the dizzy was let loose, so upon a recent troubleshooting check of the cap and rotor, I unknowingly advanced the timing. I loved the acceleration, but my gas mileage, as you can imagine, dropped.

    All things stated here, might this TBI mod be reason for the 'stumble' I'm experiencing? Am I safe to assume a guy could remove these "capacitors" and re-wire the injectors just as easy as it looks?

    Again, thank you all for your help...it is most appreciated!
    Dana Joe
    Phoenix, AZ
    HOOK 'EM HORNS!

Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 12
    Last Post: Today, 05:42 AM
  2. Replies: 2
    Last Post: 12-17-2012, 12:29 PM
  3. 98 Tahoe ignition in "run" doesn't power fuses
    By Rascl93 in forum GM Powertrain
    Replies: 2
    Last Post: 05-15-2012, 08:32 AM
  4. 2003 Suburban "Reduced engine power"
    By medicjack in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 1
    Last Post: 02-12-2010, 11:10 PM
  5. Electrical power "slip" problem on 95 burb [Expired Topic]
    By MN_Burbon in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 6
    Last Post: 08-03-2006, 11:41 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •