GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 2 12 Last Post byLast Post by
Results 1 to 10 of 18
  1. #1

    Default Fuel Mileage Help

    I have a 99 Chevy Silverado 5.3l Z71 and my MPG's have dropped from a best of 17.5mpg/avg of 15.5mpg to the low 14's the last 2 tanks. In Oct last year it started throwing the P0171 and P0174 codes. The truck still ran fine and I was still averaging 15.5mpg after clearing the codes. Near the end of Oct before a hunting trip, the code came back and I replaced the pre-cat O2 sensors(Bosch) and during the 2 round trips from Yuma to Tucson I had the best fuel mileage I have ever had with this truck during the month of Nov with no codes. Then of course the first week of December I get the same codes back so I ordered new AC Delco intake gaskets and AC Delco knock sensors and wiring harness and replaced them. Ever since I replaced those parts along with cleaning the MAF and throttle body, I am getting the crappiest fuel mileage I have ever had since I owned the truck. I checked all my spark plugs(AC Delco 41-110) the other night and they all looked good and put a bottle of Redline SI-1 fuel system cleaner in this current tank and right now I'm just a hair off of a 1/4 tank left and 250 mile on the odo. The truck idles and runs good it seems, but just crappy fuel mileage. Could the Bosch O2 sensors be the cause even though they seemed to be good in the beginning? If so, I might get AC Delco O2 sensors and take the Bosch's back for a refund. Thanks in advance for any help/suggestions.

  2. #2

    Default

    Are you checking fuel economy by filling tank and running until 1/4 tank, then refilling and calculating miles driven by gallons used? Everything else is grossly inaccurate.

  3. #3

    Default

    Yes, I fill up and let it get down to a quarter tank or a little less and fill up again. This last time, I filled up at half tank and that tank is what I am currently on now. I always keep track of mpg by the odometer and gallons needed to refill.

  4. #4
    Legend

    Join Date
    Sep 2010
    Location
    everett, massachusetts
    Posts
    1,466

    Default

    when you get the 171/174 codes the first thing to do is NOT replace the O2 sensors or any other parts. these two codes when together mean vacuum leak .

    the PCV on your vehicle along with the hoses and the seating groment must be with no defects. also the oil fill cap/dip stick secure and properly sealing the system. this includes the breather hose on the passenger side.

    when this is replaced checked and it still throws these codes you must find the vacuum leak. could be the intake manifold. using a small propane torch with a hose on the torch end probe for leaks using only a small amount of the gas. this will locate the leak in most cases. using carb cleaner will work but it will eat the plastic/gaskets wiring etc,,,.

    if you have too much gas hard to find the exact point of leak. when the gas is injested the rpm will rise.

    the reason the MPG is poor is because the pcm is seeing a lean condition so it drives the injector to open longer .

    then the other item would be the fuel pump pressure. if low the engine will run but cause a lean condition. many report that with the proper pressures the MPG improves. 52-60 psi engine on . if good should be 56psi with engine at idle. engine off key on 60 psi area higher than run . this is because the regulator has no vacuum. check that regulator hose for leaks or fuel in it. regulator can be leaking also.

  5. #5

    Default

    I have not thrown a code for the last month since I replaced the intake gaskets. I also replaced the PCV valve(fixed orfice) and hose right after the intake gasket was replaced. The fuel pump was replaced with a Delphi about 4 months ago. Would a fan clutch that is not operating correctly suck up gas mileage? It runs just a tad under the 210 mark all the time.

  6. #6
    Legend

    Join Date
    Sep 2010
    Location
    everett, massachusetts
    Posts
    1,466

    Default

    the fan clutch will go by causing overheating. the oil leaks out and the fan does not engage as much causing less flow. never seen a fan clutch fail by engaging too much .

    tire pressures will cause low MPG. fuel pressures should be checked. also a dirty fuel filter will reduce pressures.

    since you have no failure codes this is saying its all within the PCM programing spec.

    low fuel pressure will throw a code most times . if the pressure does drop too low you do get the 171/174 sometimes which also may be the vacuum leak .

    temp should be 190-5 deg f. so your indication sounds exactly on.

    the air filter may need replacement or if cleanable cleaning . if you have a KN filter follow the directions and allow time for the material should dry / oil properly.


    why did you replace the KSensor[s] ?

    if some how you used the wrong ones or installed wrong somehow it is possible they are indicating pre- ignition which would throw back the timing. an exhaust leak is also a condition that would do this effect.

  7. #7

    Default

    [QUOTE=j cat;540138]

    why did you replace the KSensor[s] ?

    I figured since I had the intake off I would go ahead and change them out since I was already in there. I used my VIN# on GM Parts Giant website to get the part numbers for both the sensors and harness. It says they are an updated knock sensor so I am wondering if I possibly need an update to the PCM from the dealer.

  8. #8
    Legend

    Join Date
    Sep 2010
    Location
    everett, massachusetts
    Posts
    1,466

    Default

    your truck/my truck 5.3L uses the ac delco 213-3521. delphi AS10017 , or a duralast [WELLS] su1282.

    what did they give you ? should go for 45-55.oo.........ea

  9. #9

    Default

    I got the AC Delco 213-3521's. Would the fixed orfice PCV have any effect on the fuel mileage? The vacuum through it compared to the original one is alot less it seems.

  10. #10
    Legend

    Join Date
    Sep 2010
    Location
    everett, massachusetts
    Posts
    1,466

    Default

    your talking about the rubber valve cover PCV grommet ? the vacuum to the PCV [hose] could be plugged up or under vaccum collapse. not properly installed or securely connected. did the hoses you replace for the pcv look and feel as the oem. if these hoses are soft this would not be good.

    pull out the pcv engine on and you should get a good vac. if its weak pull off the pcv and see if the vacuum is strong/ I would expect the engine to stall or idle to go erratic fast.

    if the wrong pcv is used or the flow of crankcase vapors is wrong this could mess up the pcm on fuel management .

    the KS I would say is good .

Page 1 of 2 12 Last Post byLast Post by

Similar Threads

  1. Replies: 10
    Last: 01-24-2013, 05:21 PM
  2. Fuel Mileage
    By AzDragonLord in forum Performance & Fuel
    Replies: 2
    Last: 12-23-2010, 05:36 PM
  3. Want better fuel mileage
    By two-dogs in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 3
    Last: 04-16-2010, 04:40 PM
  4. Fuel Mileage
    By JERMZ in forum The Coffee Shop ~ Chit Chat
    Replies: 2
    Last: 12-29-2009, 09:30 PM
  5. My fuel mileage
    By 2000liftdsuburban in forum Performance & Fuel
    Replies: 8
    Last: 10-08-2009, 05:30 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •