GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 2 of 2
  1. #1

    Default 1995 Suburban Transmission downshift and "Service Engine" light

    After about 15 min on the highway, the "Service Engine" light comes on. It stays on as long as I'm driving then shuts off when I stop. Upon restarting it stays off as long as I'm not driving at highway speeds. A new wrinkle is, when driving at highway speed, after the light comes on, at a seemingly random point, it feels like the trans downshifts for a second, engine rpm increases, then it upshifts again and rpm drops back to normal for the speed, and the "Service Engine" light goes off. This all happens very quickly, just a second or two. I have experienced the "Service Engine" light returning again after another 15 or so minutes, but not the downshift in the same trip. All trips where this has occurred have been less than an hour in length and I haven't had cause to make a longer trip since the shift issue started, so I haven't seen the combination of symptoms over a longer period yet. Yesterday I made a half-hour trip where the trans did the down-up shift on the way out, but not on the way back, same route, similar speeds each way. I'm guessing that the light and shift are related to torque converter lockup since that doesn't occur until over 40mph (about 42-43 by my observation), but the last time I had it checked no codes came up in the diagnostic. Any insights out there?

  2. #2

    Default

    Quote Originally Posted by KeithR View Post
    I'm guessing that the light and shift are related to torque converter lockup
    My guess as well.

    Quote Originally Posted by KeithR View Post
    the last time I had it checked no codes came up in the diagnostic.
    The code(s) should remain in history. Perhaps the tech is not looking at history.
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

Similar Threads

  1. 1995 Suburban Transmission downshift and "Service Engine" light
    By KeithR in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 0
    Last Post: 01-28-2013, 10:33 AM
  2. Replies: 0
    Last Post: 01-03-2013, 10:48 PM
  3. 2001 suburban with "service 4wd" on dash message light
    By junktrux in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 1
    Last Post: 10-28-2010, 04:58 PM
  4. "Service Engine Soon" light
    By gaboytroupco in forum Member Introductions
    Replies: 11
    Last Post: 11-30-2009, 07:28 AM
  5. 95 Chev Suburban "service engine light"
    By slidercoach in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 2
    Last Post: 02-11-2007, 09:11 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •